Why does Virtualbox require `sudo` to install extension packs in Manjaro?

To install extension packs for Virtualbox in Manjaro you need to use sudo, as in

sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-7.0.6a-155176.vbox-extpack

Incidentally, this means that you cannot install extension packs from the Virtualbox GUI.

All this is weird because VirtualBox is meant to provide itself for asking permission to elevate its privilege in order to install the extension packs. Indeed if you try to install an extension pack from the GUI or from the CLI without sudo, the fist thing you get is a password prompt to elevate privilege. However, even if you give the correct password the operation fails with a Code NS_ERROR_FAILURE (0x80004005) - Operation failed error.

As a matter of fact, the installation of extension packs without sudo works just fine in all other major distros (ubuntu, fedora, suse, etc.).

Any clue?

This AUR package should be simpler (and preferred) way:

pamac build virtualbox-ext-oracle
1 Like

Because VirtualBox is installed as a system package via the system package manager. The system is read-only without elevated privileges. Therefore, the extension pack also needs to be installed where the system installation can find it.

1 Like

I think that this is true of most distro and that it is the reason why the Oracle developers have explicitly assured that VBoxManage and the GUI do prompt for a password to elevate the privilege as needed when asked to manage the extensions. My question is about why on other distros entering a password lets VBox gain the privileges needed to write the extension pack in the system areas, while in Manjaro the password prompt is useless and entering the correct password does not give VBox the expected privilege elevation.

Specifically, I am looking for hints on whether this is likely to be: a packaging issue in Manjaro/Arch (that may be corrected); incorrect expectations by the VBox developers about the groups the user should be in; or something deriving from a fundamental design choice (in which case, trying to debug the packaging would just be a waste of time).

I have no issue when I download the extension pack and click on it, it opens virtualbox and I get an authorisation popup and I enter the sudo password and it installs.

Also I have no issue installing from the Virtualbox GUI, same thing happens, it asks for the sudo password when required.

That is a very valuable piece of information, because I get the authorization popup, enter the password and get the NS_ERROR_FAILURE. So it might be interesting to know which differences exist between our systems. Which groups is your user in?

Not sure that groups I belong is the reason for the error, anyway, obviously I’ve added my user to the vboxusers group. I’ve seen that a mismatch of the versions of the extension pack and virtualbox can cause that error.

Finally solved the mistery. The issue occurred to be because I had zensu installed. Removing zensu everything worked properly.

1 Like

Does not compute.

First of all, why did you install it? It’s not required by anything.

FYI, zensu is a custom package developed by @Chrysostomus. If it’s causing problems, we’ll need more detailed information to solve the issue. Feel free to open a new forum topic and we’ll be happy to investigate.

Must confess that I do not know why I had zensu installed in first place. I have a vague memory that I was experimenting with something.

I think that my issue with zensu should be repeatable. Can someone try to install zensu and then do a VBoxManage extpack install --replace <extension_pack> to see if it fails?

I had the exact same issue with two devices where zensu was installed.

So thanks for the tip :grinning:

I have not verify after removing zensu because I installed the extension pack via the command line.

I removed the extpack with the Virtualbox GUI…

Installing it via the GUI now works fine and was not possible before removing zensu.

I had the exact same issue with two devices where zensu was installed.

Same here. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.