Why does my system automatically reboots itself. How can I fix it?

It’s been almost 7 months since I am using the Linux manjaro distribution on my PC. For the last 2-3 weeks it has been rebooting itself. Earlier, the reboot happened once a few minutes after I switch on my PC from sleep or power. But in the last few days, this happening quite regular… like 3-4 times a day.

Inital kernel version: 5.15.41
Here are the solutions I tried:

  1. Upgrading the kernel to 5.17
  2. downgrading the kernel to 5.10
  3. downgrading again the kernel to 5.4
  4. Performing a full system update.

None of these fixed it.
I was wondering if someone could help me fix this issue of automatic and sudden rebooting? Is there any possible solution to this issue?

Here is the system information:

(base) [sangeet@sagar ~]$ inxi -Faz
  Kernel: 5.4.195-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4-x86_64
    root=UUID=440e41d7-9644-4f0d-b02f-b32e08ef8b8f rw rootflags=subvol=@
    quiet apparmor=1 security=apparmor
    resume=UUID=72d89c95-99c8-4863-a516-3240ce0549c4 udev.log_priority=3
  Desktop: KDE Plasma v: 5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING EDGE WIFI (MS-7C37)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.G3
    date: 09/26/2021
  Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 2274 high: 3597 min/max: 2200/3800 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3597 2: 2134
    3: 1967 4: 2199 5: 2200 6: 2198 7: 2199 8: 2198 9: 2198 10: 1960 11: 2426
    12: 1993 13: 3158 14: 2040 15: 2057 16: 2199 17: 2199 18: 2198 19: 2200
    20: 2196 21: 2199 22: 2158 23: 2589 24: 2126 bogomips: 182451
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI
    driver: nvidia v: 510.73.05 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Turing pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 2d:00.0
    chip-ID: 10de:1e89 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
    s-diag: 610mm (24")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.73.05 direct render: Yes
  Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 2d:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.4.195-1-MANJARO running: yes
  Sound Server-2: JACK v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak]
    driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 29:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlp41s0 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-4:2 chip-ID: 8087:0aa7 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 2.27 TiB used: 118.21 GiB (5.1%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXE7 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-1: / raw-size: 60 GiB size: 60 GiB (100.00%) used: 46.28 GiB (77.1%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 568 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-3: /home raw-size: 104.51 GiB size: 104.51 GiB (100.00%)
    used: 71.93 GiB (68.8%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-4: /var/log raw-size: 60 GiB size: 60 GiB (100.00%)
    used: 46.28 GiB (77.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 30 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6 maj-min: 259:6
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 35 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 485 Uptime: 5m wakeups: 0 Memory: 15.62 GiB
  used: 3.99 GiB (25.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 alt: 9.4 clang: N/A Packages: 1515 apt: 0 pacman: 1506 lib: 349
  flatpak: 0 snap: 9 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16

A few ideas that come to mind:

  • Have you checked for unusual logs? [HowTo] Find error logs
  • How hot does your CPU at work? I see it’s at 50°C after 5min of usage, which isn’t unusual per se, though you may want to check if it goes too up, and dust your computer if so.
  • A last suspect would be the power supply, from an instable electric grid to a faulty or weary PSU or plug.

Most probably a hardware issue; could be PSU or RAM, etc.
Leave it in BIOS and wait if it also reboots by itself, or in live iso or windows. That way you can be sure it’s not OS problem.
I had same thing happening to me a month ago and it was faulty (new) PSU.

1 Like

Thanks for your response. I have windows (dual boot), I will try using windows and see if similar behaviour is observed. Is there any way to detect a faulty PSU?

No. At least not without special tools and some knowledge. Try using windows for a day. If it reboots you can do a memtest. And if that works fine, well… you’ll have to go on a hunch and get a new PSU or borrow it somewhere.

1 Like

I would go the proposed ways and also let the PC run overnight with the BIOS window opened. If the PC shows the Windows or Linux login window next morning, it did a reset during the night.


A post was split to a new topic: System instability