Why can't I manage to install VirtualBox?

Hey all, my end goal is to run a virtual machine of windows for gaming, that’s it. I haven’t been able to get it working in the on and off times I’ve tried in months! I got it close before but it would show 100% cpu usage on the guest while the host was at 60%, so I scrapped it and started over. Now I’m trying to install it using either the pamac gui or the wiki with cli from this link, now the one catch with that is that when I run " mhwd-kernel -li" I get
5.10.0-1-MANJARO (linux510)
The following kernels are installed in your system:

  • linux414
  • linux510
  • linux57
  • linux58
  • linux59
    So I tried the command it had using 510 but it didn’t like that, so I tried 59, and that installs, but then it doesn’t get these modules loaded correctly similar to this thread, but none of the solutions in that thread helped, any suggestions or is there info I could provide to help out?

Those kernels are long EOL (End Of Life) and are no longer in the repos. Neither are the VirtualBox modules.

Please see:

I just checked that link out, I was there before, it didn’t have any new things for me to do, I’ve done all those things it listed, using kernel 59 still, no joy, I get this when running the virtual machine btw

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing


as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.