Who has argon case fan script working?

Opened a terminal and entered:

curl https://download.argon40.com/argon1.sh | bash

And it won’t d/l as it requires apt-get

Edited the sh after d/l it with got clone and changed apt-get to pacman.

Now it wants raspi-gpio.

Okbso I see the list and some names are available from the aur but not the python 3 named ones

OK so after I install all the files Ivan how much of this can I trash and still run the sh file to do the other portion of the install?

This script is in AUR AUR (en) - argonone-git

1 Like

Lol I missed that. TY! Clearly its past my bedtime.

55c 40%
60c 70%
65c 100%

I guess that sounds reasonable

Tried it at always on and I can’t hear it at all

Enabling UART 1 in /boot/config.text give me a kernel startup panic

enable uart=1 i

Is necessary for the fan in Debian but is causing a kernel panic on my manjaro mate arm install.

Maybe the one written in C works? But differently. Why uart=1 causes kernel panic?

Personally, I much prefer the argonone-c-git package. I dislike dealing with the python gpio package.
You can configure it like:
$ sudo nano /boot/config.txt


(no spaces)

You can check the settings or change them while running:
$ argonone-cli -d

INFO:  Running under normal user some features may not work.
Fan Status ON Speed 33%
System Temperature 43°
Hysteresis set to 5°
Fan Speeds set to 33% 66% 100%
Fan Temps set to 45° 50° 55°
Fan Mode [ AUTO ] 
Fan Speed Override 0% 
Target Temperature 0° 
Daemon Status : Waiting for request
Maximum Temperature : 49°
Minimum Temperature : 29°
Daemon Warnings : 0
Daemon Errors : 0
Daemon Critical Errors : 0

Edit: There is a chance the python gpio package will get updated after Debian 11 is released, but don’t hold your breath.

1 Like

@0n0w1c created a startup command in mate to set cooling to 50 degrees before finally going to bed. I’ll refine this some more in a bit. TY for those commands.

I used

argonone-cli -c 50

and added it to my mate > menu > system > control center > startup applications > add and created an entry for the case fan to always cool it to 50 degrees

1 Like

Make sure to “commit” that change, for it to take effect:

argonone-cli -r

1 Like

Can I make one long command by putting && between them? I just added a -r after 50. That seems to work.

TY for the tip

I have not explored the possibilities of interactively adjusting the settings, but I would expect using && would work. I just set it in the config.txt. I have yet to have the RPi4 throttle even without the fan, just using the passive cooling of the Argon One case. Without the fan, my case has become warm enough (with the M.2 SSD) to make the sticky stuff for the rubber feet soft and the feet moved while building a kernel. My case sits on a slight incline. So I feel better with the fan running.

1 Like

I tried


In /boot/config.text but it doesn’t seem to take.

I can type

argonone-cli -c=50


argonone-cli --cooldown=50

And I can see it in effect when I do

argonone-cli -d

But when I autostart it from mate startup I can’t see it when I do the -d command

I made a cooldown.sh file and chmodded it and used that as the startup file and it won’t work but if I do

sh ./cooldown.sh into a terminal I can see the effect with the -d command


You caused me to look at the gitlab page, I did not know about the cooldown option. The developer has done some work since the previous update of the package. It now has new options, even for missing gpiomem and the vcio… very interesting.

It looks like cooldown is only interactive, or he has not yet documented how to set it in config.txt. Your guess would have been my guess, to get it to work from config.txt

1 Like

No matter what I try it won’t autostart at login. Will only run when entered into a terminal

Maybe it has to be activated after some other process. Try putting a sleep in the script say @10 seconds before the script is run.

1 Like

The argonone daemon starts before X loads, so there should not be a timing issue with autostarting. So likely, either the .desktop fails to execute or it fails to execute properly. The daemon creates a fairly detailed log of everything it does: /var/log/argononed.log

1 Like

I had gone as high as 15

Looking at the log it seems that cooldown mode is not meant to be a fixed setting as once cooldown is achieved it switches back to auto mode

Ah, that makes sense, and it explains why it is not set from config.txt.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.