White screen with cursor after login. tty works

Hi everyone, and thank you for clicking on this topic!
I installed Manjaro a few months ago, and it’s going great! Unfortunately I recently updated to the last suggested kernel (Linux 6.1), but one of my three monitors stopped working. Booting into the older kernel fixed everything immediately.
I then ran a complete update with pacman (i run those regularly, at least once every two weeks).
Upon reboot, today, the usual login screen was showed, but after logging in there is only a white screen with a cursor. Using Ctrl+Alt+F2 I went to another tty (they all work fine) and:

  • tried running pacman-mirrors -f and pacman -Syyu, but nothing new was there
  • startx starts another white desktop session with cursor
  • returning to Linux 6.1 the same monitor stopped working, however the desktop flashed white with a very high frequency (10 times a second or so) but I could now see the normal desktop in the background (and it is responsive, it works)
  • removing ~/.config/plasma-org.kde.plasma.desktop-appletsrc didn’t work
  • reinstalling the drivers with mhwd did not help
  • creating a brand new user did not work

My GPU is the AMD 7950X’s integrated graphics.

What steps should I take?
Thank you in advance!

1 Like

I was able to partially solve the issue by disconnecting two of my three monitors. I am going to update this as soon as I am able to get them working again.

Can anyone give me some advice?

I am expiriencing the same issue since yesterday with KDE Plasma after upgrading.

Dual-Monitor setup, Ryzen 5 7600X, also iGPU, 6.1 Kernel.

I did not have the time in further investigating the error, but i tried a lot of things OP tried without success.
Got a desktop back by using cinnamon instead of KDE, but that only works after a new login. If i lock an unlock my desktop the screen goes white, even with cinnamon.

In both cases, KDE and cinnamon, it is possible to see the “real” desktop for a fracture of a second when switching to tty and back. So it seems something may be overlaying the desktop.

I have the same issue, if I disable “Compositor” using shift+alt+F12 it stops blinking, except on full screen video or the lock screen (login screen is fine).

I have ryzen 9 7950x with integrated graphics as well.

Thank you for the answers! I still couldn’t find a better solution than detaching one of my monitors. I saw matervinte’s video on another topic and it is the same problem I have when running 6.1. I will try to disable the compositor. It is clear that our iGPUs didn’t like something in the last updates!
Disable the compositor did, in fact, help, but only with 2 monitors. With all three monitors connected, it still won’t work.

1 Like

New Kernel 6.1.9 fixes the issue:


Tried it just now and worked for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.