White screen “Oh no! something has gone wrong” after software update

After I run a normal update in Pacman and reboot, the white screen happened.
The possible error from gdm-x-session: no screens found

inxi -F
  Host: someone Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 
  Desktop: GNOME 40.4 Distro: Manjaro Linux 
  Type: Laptop System: MECHREVO product: X3 Series GK7CP6R v: Standard 
  serial: <superuser required> 
  Mobo: MECHREVO model: GK7CP6R v: Standard serial: <superuser required> 
  UEFI: American Megatrends v: N.1.03 date: 04/01/2019 
  ID-1: BAT0 charge: 30.5 Wh (99.0%) condition: 30.8/46.7 Wh (65.9%) 
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP cache: 
  L2: 12 MiB 
  Speed: 900 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900 
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel 
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia 
  v: 470.63.01 
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo 
  Display: server: X.org 1.20.13 driver: loaded: modesetting,nvidia 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.2 
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes 
  Sound Server-2: PipeWire v: 0.3.37 running: yes 
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi 
  IF: wlo1 state: up mac: 38:00:25:16:0e:a9 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 
  IF: enp4s0 state: down mac: b0:25:aa:30:18:d7 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 476.94 GiB used: 268.55 GiB (56.3%) 
  ID-1: /dev/nvme0n1 model: PM8512GPTCB3B-E84 size: 476.94 GiB 
  ID-1: / size: 97.93 GiB used: 60.5 GiB (61.8%) fs: ext4 
  dev: /dev/nvme0n1p1 
  ID-2: /boot/efi size: 512 MiB used: 288 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p3 
  ID-3: /home size: 369.53 GiB used: 208.05 GiB (56.3%) fs: ext4 
  dev: /dev/nvme0n1p2 
  Alert: No swap data was found. 
  System Temperatures: cpu: 48.0 C mobo: 47.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 353 Uptime: 9m Memory: 15.49 GiB used: 4 GiB (25.9%) Shell: Zsh 
  inxi: 3.3.06

But after I login in to tty2, I can use startx to run the gnome.

after I using startx run the gnome on the tty2, I can found 2 xorg in the nvidia-smi:

|    0   N/A  N/A       575      G   /usr/lib/Xorg                       4MiB |
|    0   N/A  N/A      1336      G   /usr/lib/Xorg                       4MiB |
  • Kernel 5.13 is EOL so please install both 5.4 and 5.10 LTS (Long Term Support) and see which one of the two troubles you least.



Did that work? If yes, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.