Whisker Menu resizing

I suppose this is going to be a longshot hope, but here goes anyway.

Since the last recent kernel update a few things have gone awry, mainly to do with my AUR packages, but I managed to fix them. However, I do have an issue with my whisker menu (WM) properties, in that I can no longer resize it by dragging the edges/corner of the WM pop-up…

I can’t see anything in the WM properties which relate to adjusting the size of the pop-up. I tried removing WM then adding it back to the panel, but the problem remains. I’ve also tried using different themes, but to no avail.

Other than removing Xfce, then re-installing it - and I don’t know if that will even work - does anyone have any ideas on how to restore the sizing of WM?

Interesting bug. I see i have it too. Should have appeared sometime after 9 August because i resized on that date (maybe later but on 9.8. i installed some stuff and rearranged the menu, so i resized it).

Edit: i’m doing the research now. Seems known bug of the 2.8.0. update that was released on 29.8. and was pushed to manjaro on 10.9. Something to do with moving the settings to xconf.

Sounds like closed matter to me, and we can thank Wayland even if we do not use it.

The only way to resize now leaves to manually type dimensions - right click on the start/whisker/manjaro button - properties.

Hold on a second. This problem has not been solved. Far from it, so why are you shutting this down?

Also it’s an issue that so far only seems to be affecting Manjaro (maybe Arch as well). I also use Linux Mint and everything works just fine there so far, and just had a recent kernel update there too. The little I know about Wayland from what I remember from using Ubuntu was that it was an alternative to x11, and at login I had the choice to use it or not. AFAIK I’m not running Wayland at all. So I don’t see what that has to do with anything.

Ok i unsolved it but i won’t change anything as the lead developer of whisker said the function will not be supported anymore. Your mint works because it is below version 2.8.

I didn’t know WM even had an official version number as it’s just a plug-in. But yes, my version on Mint is 2.7.2-1, so it will be interesting to see if Mint update it in the near future.

Where is your source about the lead developer of whisker saying he won’t support WM anymore? I find that rather extraordinary after all the time that WM has been around. I’m sure some programmer will eventually come up with a solution for this

The link is above. He removed the mouse resizing in ver 2.8. and most probably it will not come back.

So there is no real solution to this topic - only a workaround and an explanation, both in the second post.

A rolling release like manjaro has some dowsides too, with the constant updating to newer versions.

As posted in another topic: “update is the process of replacing the old bugs with entirely new ones” :grin:

Abbreviation WM is usually used for referring to Linux window managers
Xfce has xfwm window manager

Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm

Developer has stated they cannot implement resizing Whisker menu in the usual manner because it is not supported by Wayland and they are “not willing to maintain multiple code paths”

Menu width and height can be adjusted in Whisker menu preferences


Wayland is intended to replace X.Org, but it may be a while before Xfce has Wayland support