Which driver do I have to install to get AMD GPU working in Blender 3.2?

Hey guys can someone tell me which driver should I install to get Blender 3.2 working with AMD GPU? I have an RX 570, so from 3.0 version Blender only supports HIP driver, I tried to search in Manjaro/Arch Wiki if there’s any information about which driver should I install, but it only says:

Note: Blender developers decided to switch another API (HIP) and deprecate OpenCL support. This will happen in Blender 3.0 release (4th December 2021). More information.

So, Blender 3.2 was released with support to HIP in Linux three days ago, when I try to search for “hip amd” in AUR there’s a lot of options, I tried to install aur/rocm-hip-runtime 5.1.3-1 but my pc ended up running out of memory and with 100% CPU usage, is that the correct one?

inxi -Fxz                                                        ✔ 
  Kernel: 5.15.48-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: GNOME v: 42.2 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2006
    date: 11/13/2019
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1686 high: 3642 min/max: 1550/3400 boost: enabled
    cores: 1: 3642 2: 1555 3: 1524 4: 1546 5: 1521 6: 1546 7: 1441 8: 1344
    9: 1323 10: 1546 11: 1468 12: 1779 bogomips: 81470
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN 4 bus-ID: 08:00.0
  Device-2: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon gpu: amdgpu
    resolution: 1920x1080~70Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel bus-ID: 3-1:2 v: kernel
    bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3
  Device-3: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
  Device-4: FIFINE Microphones K670 Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:3
  Sound Server-1: ALSA v: k5.15.48-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 447.13 GiB used: 220.2 GiB (49.2%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-1: / size: 58.76 GiB used: 32.37 GiB (55.1%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 196.9 MiB used: 274 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 379.8 GiB used: 187.83 GiB (49.5%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: file size: 1024 MiB used: 0 KiB (0.0%) file: /swapfile1
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1206
  Processes: 328 Uptime: 7m Memory: 15.55 GiB used: 2.28 GiB (14.7%)
  Init: systemd Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1413
  Shell: Zsh v: 5.9 inxi: 3.3.18
1 Like

Maybe you should look here:

opencl-amd in the AUR.

I already have this one, and it’s up-to-date, still there is no option to select my graphics card in my settings, in version 3.2 in version 2.93 it works correctly. I think maybe it’s opencl-amd-dev, cause the description is different, in dev it says “HIP SDK”, look:

aur/opencl-amd-dev (+3 0.15) 
    OpenCL SDK / HIP SDK / ROCM Compiler. This package needs at least 10GB of space.
aur/opencl-amd (+118 0.68) (Installed: 20.40.1147286-1)
    ROCr OpenCL stack, supports Vega 10 and later products - Legacy OpenCL stack (Proprietary), supports legacy products older than Vega 10 - This package is intended to work along with the free amdgpu stack.

Thanks for your answer, I’ve read it a few times but I didn’t understand anything at all, I think it’s too technical for me, but I’m researching it and visiting some Blender forums, maybe there’s some information about it.

To my understanding, after Blender 3.0 it’s no longer support the old opencl rendering on linux and use AMD HIP supported driver on RDNA GPUs instead of that (Blender 3.2 Debuts With AMD GPU Linux Rendering Support - Phoronix).

So as it says in the link:

This is for RDNA/RDNA2 GPUs and works with the Radeon Open eCosystem (ROCm) compute stack / HIP.

And RX 570 is Polaris Architecture I have to wait for a new version of the driver that supports Polaris Architecture?

Only AMD can answer that question. Maybe you can ask them to support Polaris GPUs for their HIP driver. Or ask Blender dev to bring their old opencl renderer back.

I’m using Blender too and that what makes me stuck with the green team for years. :expressionless:

Yeah, I’m reading about it right now, AMD support for Blender is available only for RDNA cards, which are mentioned in the link: Next level support for AMD GPUs — Blender Developers Blog those who don’t have an RDNA GPU are stuck on version 2.93 and earlier until they release a driver that supports older cards.

What is really very sad, I’ve been using version 2.93 since December, it’s been more than 6 months using an obsolete version and no support forecast for GPUs like mine…

what do you mean by “green team?” sorry, not fluently

It’s nVIDIA. :slightly_smiling_face:

1 Like