Where is kernel 6.2?

Why is Manjaro still using kernel 6.1.x rather then 6.2.1? And why is 6.2 not in the kernel tool?

It is, right? You can install it with pamac install linux62.

6.2.0 is currently in Unstable branch.


Because it’s new - released a few days ago.
And because Manjaro stable takes a while to get the newest stuff - as you should know.

Arch isn’t even on 6.2 yet… Unstable has 6.2.0-1.

Hi @FreeRangeTux,

Pobably somewhere with your out-of-sync mirrors. I’m running 6.2 quite happily:

$ mhwd-kernel --listinstalled
Currently running: 6.2.0-1-MANJARO (linux62)
The following kernels are installed in your system:
* linux515
* linux61
* linux62


Try updating your mirror:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

While we are at it - have anyone tried retbleed=stuff option? Lockups were real on my machine when I tried that using 6.2 rc7.

Not me. Sorry. My stuff is anyway so plain vanilla I doubt it’ll affect me.


1 Like

Also, even with linux62 available, linux61 will still be available for as long as it is supported, because you can have multiple kernels installed on Manjaro.


… Question Mark

how are or where we “at it”?

kernel 6.2.1 on unstable reports 6.2.0

uname -a                                                                                                                    ✔ 
Linux 6.2.0-1-MANJARO #1 SMP PREEMPT_DYNAMIC Sat Feb 25 17:22:54 UTC 2023 x86_64 GNU/Linux
pacman -Qi linux62                                                                                                        1 ✘ 
Name            : linux62
Version         : 6.2.1-1
Description     : The Linux62 kernel and modules
Architecture    : x86_64
URL             : https://www.kernel.org/
Licenses        : GPL2
Groups          : None
Depends On      : coreutils  linux-firmware  kmod  mkinitcpio>=27
Optional Deps   : wireless-regdb: to set the correct wireless channels of your country [installed]
Required By     : linux62-virtualbox-host-modules
Optional For    : base
Conflicts With  : None
Replaces        : None
Installed Size  : 180,78 MiB
Packager        : Manjaro Build Server <build@manjaro.org>
Build Date      : Sat 25 Feb 2023 04:07:12 PM CET
Install Date    : Sun 26 Feb 2023 03:35:37 AM CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

I meant “since linux62 is mentioned” - I assumed there would be people who use linux62 here, hence my question to those who could have tried that option.

1 Like

Thanks @Zesko Didn’t see that thread :pensive:.

I got modules loading error after installing kernel 6.2, so I went back to 6.1 for now. I will try 6.2 again, when it lands on testing (meaning: it won’t be experimental in testing anymore).

@michaldybczak that should be fixed since yesterday when you take it from unstable branch.

1 Like

Locustus rolls eyes so hard over this they are now stuck rolled back. This is not in most distros yet. You would know that if you had done the research.


Linux 6.1 received LTS status, by the way.


Yes I am aware of the LTS status of 6.1. None of that changes what I asked about. Regardless this thread has answered my question.

I have been running it for a couple days without issue.