Where in System Settings can I set default option for Logout screen?

When I installed a fresh Manjaro KDE on my laptop I could not find where to set the default option for the Logout screen. I want it to be Shut Down instead of Log Out. My desktop runs a Manjaro KDE installed long ago where the default option is set to Shut Down, and I have a vague recollection of setting that somewhere in System Settings.

I compared the settings in my desktop and laptop profiles and found out that ~/.config/ksmserverrc on my desktop contains the setting ‘shutdownType=2’, and the file on the laptop had no such setting. Some experimenting revealed that shutdownType=1 is Restart and shutdownType=0 is Log Out. Not setting shutdownType in ~/.config/ksmserverrc seems to make the default 0 and thus Log Out becomes the default option on the Logout screen.

Has the option to set the Logout screen default been removed from System Settings - Workspace - Startup and Shutdown - Desktop Session ?

1 Like

These settings are in power management section

1 Like

Where in these settings can I choose the default for the prompt log out dialog?

The setting you have marked opens the log out dialog, and on my laptop and desktop the chosen setting is already “Prompt log out dialog”. I want to choose the default for the dialog that appears when I press the power button or press Ctr-Alt-Delete.


[Yes, I know I’m bumping this topic from limbo, but i think it could be useful to someone else.]


Hello everyone

I had the same problem and couldn’t find the option via GUI. I think it no longer exists in the GUI.

Your initial post gave, at least, half the answer.
This actually happens in the file:
~/.config/ksmserverrc

I also have two machines, one recently installed and the other running for over a year. I was able to compare that file.

The oldest has the default logout screen on shutdown
and the line:

[$Version]
update_info=ksmserver_update_loginMode_value.upd:ksmserver_update_loginMode_value_default_enum

[General]
loginMode=restoreSavedSession
shutdownType=2
 
[Subsession: .....[etc...]]

(I have more lines, but i think they are unrelevant here.)

The freshly installed one has:

[$Version]
update_info=ksmserver_update_loginMode_value.upd:ksmserver_update_loginMode_value_default_enum

[General]
loginMode=restoreSavedSession
shutdownType=0

(and nothing else)

Which I modified
shutdownType=0
to
shutdownType=2
and saved the file.
The change was taken into account immediately.
Which set the shutdown option of the logout screen as the default choice.

I think that if this file does not exist you could try to create it and put the lines (which I found common between my two machines) with the setting in question on 2 (maybe do a Timeshift before, not so usefull but it does not eat bread, so, why not):

[$Version]
update_info=ksmserver_update_loginMode_value.upd:ksmserver_update_loginMode_value_default_enum

[General]
loginMode=restoreSavedSession
shutdownType=2

I know if after all this time you still need the answer. In any case, I like to think that it could help others, as I did with your post.


Regards
NomenNiesco

~/.config/ksmserverrc

[General]
shutdownType=2

Will set the default selection when, ex, tapping the power button, to “Shut Down”.

(my file does appear in its full state as yours above. But the pertinent section/option is the part here)

And to answer some of the original query;

Not moved - removed.
This option does not exist in Plasma 5 any longer, and does not exist in Plasma 6 as of this writing.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.