When starting, Manjaro shows some errors and then loads desktop. Keyboard and mouse not working so I am stuck

Thanks for any help. Beginner here so please be patient.

I was updating some packages and after a restart Manjaro started booting with an error message reading:

[FAILED] failed to start CUPS Scheduler
[FAILED] failed to start CUPS Scheduler
[FAILED] failed to start CUPS Scheduler
[FAILED] failed to start CUPS Scheduler
[FAILED] failed to start accounts service

After some time Manjaro loads into my desktop but mouse and keyboard are disabled.


– Mouse and Keyboard work in BIOS and GRUB menu
– After reading some support entries I tried by pressing Alt + F2 to login manually and run some pacman database sync. The issue is that while I am typing the commands linux loads the desktop.
– When getting stuck in the i3 desktop I can see the NVIDIA text at the bottom.
– I have tried loading with these kernels: 6.1.33 / 5.15.12 / 5.10.174

Any ideas how to proceed?

Thanks for any help in advance.

That is odd.

Do you mean that when you reach the login screen for manjaro, you press alt+f2 and after logging into the new tty with your username and pass, the desktop suddenly loads?

My user logs in automatically without arriving to the login/pass screen. In this instance it arrives with keyboard and mouse locked. However, after the error shows up when booting I press Alt + F2, I get a console login/pass prompt and then I have access to the console ( keyboard works here) . Then after a few seconds it launches automatically the desktop,

systemctl status accounts-daemon
systemctl status cups

Maybe just look at all failed things:

systemctl --failed

You may also use history to view previous commands … or to specifically look at package exchanges you could use something like

tail -n100 /var/log/pacman.log

Oh, wait, you typed alt+f2, not ctrl+alt+f2, I misread that and I got unlucky when thinking.

I’m not even sure what alt+f2 is supposed to do default, on my computer (KDE plasma) it opens the kwin search manager.

This is when being a beginner kicks. Typing on my console lasts very little so I can’t type all that.
If only I could type one line to stop it to load the desktop that’ll be a good step.

II am gonna try that in the morning. Thanks for the attention @bedna

It’s a Vostro 7500, right? Is your printer plugged in to a USB port? Do your USB ports fail to work with other equipment too, eg a flash drives? If that is the case check in your Bios that “Enable external USB ports” is not set to ‘disabled’ (If it is, mouse and keyboard will work in bios but stop working at desktop.).

The keyboard is working when launching the console before going to the desktop and getting unresponsive. I even plugged a wireless keyboard and it works in the console and both keyboard and mouse work in the bios.

I tried only ctrl + alt + f2. It loads the console but then leaves the console and jumps into the desktop.

I wonder if killall plasmashell will work? … also, does the keyboard work when booted into a live session?

They are commands to go in the terminal…

Sure I’ve used that from a TTY before due to a lockup (on Mint though, not used that for years). I guess the timing would have to be right.

What puzzles me is it switching to the desktop whilst in a TTY, assuming this is the case.

I asked for logs … timing does not matter.

1 Like

OK I’m going to take a stab at his. The keyboard and mouse working in bios has nothing to with Manjaro because it hasn’t even loaded yet. Are you using a wireless mouse and keyboard. If so don’t. Now the brute force solution is to download a new ISO and reinstall. Now tell us what Nvidia drivers you use and tell us what if anything is broken.

SOLVED. Thanks everyone for the suggestions and support. I fixed it by doing this:

  1. I had to load a USB with a Manjaro ISO image using Rufus.
  2. Then I changed the setting of the BIOS to load Manjaro from the USB
  3. On Linux on the console I set things up for updating my broken local Linux using:
    manjaro-chroot -a ( Console characters turn red )
  4. Once I got there, I was able to sync the servers database and updated my installation using:
sudo pacman-mirrors -f 5 && pacman -Syyu

I had to repeat step 4 a few times after some errors related to the Ghostscript library. ( This has created issues before)

Grub was not showing the Windows option but I followed the guide on this post and did sudo update-grub

and my Nvidia Drivers are not properly updated. However I am gonna leave that in a separate entry.

1 Like

Make sure to run

sudo update-grub
1 Like

I could’t try this. I went into using the ISO.

Thanks! Now GRUB is showing the Windows option.

Hi @fbt89 I ran a portable USB Manjaro and fixed the missing libraries and updates.