When i open a game it always goes black

I looked at the old same problem at forum but i can’t solve this problem. Please help me. This is my system info.

  Kernel: 6.5.13-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=f058ba92-13a2-4169-bd4f-1349d77e5387 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1070
    serial: <superuser required>
  Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1070 serial: <superuser required>
    UEFI: HUAWEI v: 1.06 date: 09/14/2020
  ID-1: BAT0 charge: 47.6 Wh (100.0%) condition: 47.6/54.9 Wh (86.6%)
    volts: 8.6 min: 7.6 model: Sunwoda- HB4593R1ECW-22T0 type: Li-ion
    serial: <filter> status: full cycles: 705
  System RAM: total: 16 GiB note: est. available: 15 GiB used: 3.68 GiB (24.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1429 high: 1531 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1398 2: 1398
    3: 1400 4: 1397 5: 1531 6: 1400 7: 1397 8: 1397 9: 1504 10: 1433 11: 1397
    12: 1497 bogomips: 71898
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: Huaqin driver: amdgpu v: kernel arch: GCN-5
    code: Vega process: GF 14nm built: 2017-20 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
    chip-ID: 1002:1636 class-ID: 0300 temp: 52.0 C
  Device-2: IMC Networks HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:3 chip-ID: 13d3:5451
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org v: with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2160x1440 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
    res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
    diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM
    16.0.6 DRM 3.54 6.5.13-1-MANJARO) device-ID: 1002:1636 memory: 500 MiB
    unified: no
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.1.9-manjaro1.1
    device-ID: 1002:1636 surfaces: xcb,xlib
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Huaqin
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Huaqin driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Huaqin driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.13-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: & Tele RSH driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 1358:c123
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 50.6 GiB (10.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
    SDBPNTY-512G-1027 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 11120000 temp: 40.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 50.6 GiB (10.8%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: f058ba92-13a2-4169-bd4f-1349d77e5387
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 4641-299E
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-2:2 info: Areson Corp 2.4G Receiver type: keyboard,mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
  Device-2: 1-4:3 info: Shenzhen Goodix Fingerprint Device
    type: communication,CDC-data driver: N/A interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 27c6:5110 class-ID: 0a00 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-3:2 info: Realtek Bluetooth Radio type: bluetooth driver: btusb
    interfaces: 2 rev: 1.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 500mA chip-ID: 1358:c123 class-ID: e001 serial: <filter>
  Device-2: 3-4:3 info: IMC Networks HD Camera type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
  Hub-4: 4-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 67.0 C mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (rpm): N/A
  Processes: 334 Uptime: 1h 16m wakeups: 0 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1389 pm: pacman pkgs: 1380 libs: 391
  tools: gnome-software,pamac,yay pm: flatpak pkgs: 9 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.31


Thanks for the system info … but can you include some more about the issue?

Is it a single game in particular or ‘all games’ (that you have tried)?

Are these standalone games? Using a launcher? Steam?

In any of these cases is it possible to retrieve logs of the errors?

I am trying to install League of Legends and CS 1.6. Both games screen turned black. After some research I installed lutris and after lutris I could see the screen during installation. But now I can’t reach to game’s launcher.

This is my wine debugger program error details.

0x71ffe566 libcef+0x26fe566: int3
Module  Address                 Debug info      Name (127 modules)
PE        400000-  7a8000       Export          riotclientuxrender
PE-Wine 10000000-10002000       Deferred        usp10
PE-Wine 6c5d0000-6c60a000       Deferred        msv1_0
PE-Wine 6c610000-6c638000       Deferred        kerberos
PE-Wine 6c640000-6c65b000       Deferred        dhcpcsvc
PE-Wine 6c660000-6c681000       Deferred        ncrypt
PE-Wine 6c690000-6c6e3000       Deferred        dxva2
PE-Wine 6c6f0000-6c848000       Deferred        d3d9
PE-Wine 6c850000-6c9b6000       Deferred        cryptui
PE-Wine 6c9c0000-6c9e4000       Deferred        compstui
PE-Wine 6c9f0000-6ca8c000       Deferred        winspool
PE-Wine 6ca90000-6cc8d000       Deferred        comdlg32
PE-Wine 6cc90000-6cce2000       Deferred        mpr
PE-Wine 6ccf0000-6ceaa000       Deferred        wininet
PE-Wine 6ceb0000-6d119000       Deferred        urlmon
PE-Wine 6d120000-6d15f000       Deferred        credui
PE-Wine 6d160000-6d3c3000       Deferred        d3d11
PE-Wine 6d3d0000-6d7f9000       Deferred        opengl32
PE-Wine 6d800000-6ea4c000       Deferred        wined3d
PE-Wine 6ea50000-6eb64000       Deferred        dxgi
PE-Wine 6eb70000-6eb8f000       Deferred        dwmapi
PE-Wine 6eb90000-6ebb6000       Deferred        userenv
PE      6ebc0000-6ec7a000       Deferred        chrome_elf
PE      6ec80000-6ee80000       Deferred        ffmpeg
PE-Wine 6ee80000-6ef18000       Deferred        wintrust
PE-Wine 6ef20000-6ef4b000       Deferred        hid
PE-Wine 6ef50000-6ef77000       Deferred        wtsapi32
PE-Wine 6ef80000-6f3d2000       Deferred        comctl32
PE-Wine 6f3e0000-6f534000       Deferred        uiautomationcore
PE-Wine 6f540000-6f5fd000       Deferred        oleacc
PE-Wine 6f600000-6f67f000       Deferred        netapi32
PE-Wine 6f680000-6f70d000       Deferred        secur32
PE-Wine 6f710000-6f774000       Deferred        msacm32
PE-Wine 6f780000-6f8f1000       Deferred        winmm
PE      6f900000-752c4000       Export          libcef
PE-Wine 75810000-7582a000       Deferred        version
PE-Wine 75830000-75a8c000       Deferred        dbghelp
PE-Wine 75a90000-75ad1000       Deferred        jsproxy
PE-Wine 75ae0000-75bdb000       Deferred        winhttp
PE-Wine 75be0000-75bff000       Deferred        nsi
PE-Wine 75c00000-75c74000       Deferred        iphlpapi
PE-Wine 75c80000-75ef8000       Deferred        dwrite
PE-Wine 77fa0000-78007000       Deferred        propsys
PE-Wine 786f0000-78790000       Deferred        uxtheme
PE-Wine 78790000-787e6000       Deferred        winex11
PE-Wine 78890000-788ef000       Deferred        imm32
PE-Wine 788f0000-78977000       Deferred        ws2_32
PE-Wine 78980000-795ed000       Deferred        shell32
PE-Wine 795f0000-795ff000       Deferred        psapi
PE-Wine 79600000-79640000       Deferred        shcore
PE-Wine 79640000-79726000       Deferred        shlwapi
PE-Wine 79730000-79ae4000       Deferred        oleaut32
PE-Wine 79af0000-79cfa000       Deferred        rpcrt4
PE-Wine 79d00000-79e3a000       Deferred        combase
PE-Wine 79e40000-7a27c000       Deferred        ole32
PE-Wine 7a4e0000-7a521000       Deferred        dnsapi
PE-Wine 7a530000-7a567000       Deferred        win32u
PE-Wine 7a570000-7a78d000       Deferred        gdi32
PE-Wine 7a790000-7ac69000       Deferred        user32
PE-Wine 7ac70000-7af4d000       Deferred        crypt32
PE-Wine 7af50000-7af93000       Deferred        bcrypt
PE-Wine 7afa0000-7b29a000       Deferred        ucrtbase
PE-Wine 7b2a0000-7b328000       Deferred        sechost
PE-Wine 7b330000-7b5ba000       Deferred        msvcrt
PE-Wine 7b5c0000-7b6a5000       Deferred        advapi32
PE-Wine 7b6b0000-7bbbe000       Deferred        kernelbase
PE-Wine 7bbc0000-7bd22000       Dwarf-4-5       kernel32
PE-Wine 7bd30000-7bfff000       Dwarf-4-5       ntdll
ELF     f660e000-f6614000       Deferred        winspool.so
ELF     f6614000-f66b8000       Deferred        opengl32.so
ELF     f66b8000-f66c0000       Deferred        libxfixes.so.3
ELF     f66c0000-f66cd000       Deferred        libxcursor.so.1
ELF     f66cd000-f66e2000       Deferred        libxi.so.6
ELF     f66e2000-f66f2000       Deferred        libxrandr.so.2
ELF     f66f2000-f6700000       Deferred        libxrender.so.1
ELF     f6700000-f6708000       Deferred        libxxf86vm.so.1
ELF     f6708000-f670f000       Deferred        libxdmcp.so.6
ELF     f670f000-f673c000       Deferred        libxcb.so.1
ELF     f673c000-f688e000       Deferred        libx11.so.6
ELF     f688e000-f68a4000       Deferred        libxext.so.6
ELF     f68a4000-f6930000       Deferred        winex11.so
ELF     f6930000-f6988000       Deferred        libgssapi_krb5.so.2
ELF     f6988000-f6a5e000       Deferred        libkrb5.so.3
ELF     f6a61000-f6a67000       Deferred        dwrite.so
ELF     f6a67000-f6a6d000       Deferred        crypt32.so
ELF     f6a6d000-f6a79000       Deferred        bcrypt.so
ELF     f6a9d000-f6c54000       Deferred        libunistring.so.5
ELF     f6c54000-f6ce6000       Deferred        libgmp.so.10
ELF     f6ce6000-f6d30000       Deferred        libhogweed.so.6
ELF     f6d30000-f6d84000       Deferred        libnettle.so.8
ELF     f6d84000-f6e51000       Deferred        libzstd.so.1
ELF     f6e51000-f7000000       Deferred        libp11-kit.so.0
ELF     f7000000-f723a000       Deferred        libgnutls.so.30
ELF     f723b000-f7240000       Deferred        libxau.so.6
ELF     f7240000-f7245000       Deferred        msv1_0.so
ELF     f7245000-f724c000       Deferred        netapi32.so
ELF     f724c000-f7254000       Deferred        libkeyutils.so.1
ELF     f7254000-f7264000       Deferred        libkrb5support.so.0
ELF     f7264000-f726e000       Deferred        libffi.so.8
ELF     f726e000-f7286000       Deferred        libtasn1.so.6
ELF     f7286000-f72a7000       Deferred        libidn2.so.0
ELF     f72a7000-f7355000       Deferred        libbrotlienc.so.1
ELF     f7358000-f735d000       Deferred        libcom_err.so.2
ELF     f735d000-f738c000       Deferred        libk5crypto.so.3
ELF     f738c000-f7394000       Deferred        kerberos.so
ELF     f7394000-f739e000       Deferred        secur32.so
ELF     f748a000-f74b5000       Deferred        libexpat.so.1
ELF     f74b5000-f7508000       Deferred        libfontconfig.so.1
ELF     f7508000-f75a9000       Deferred        libpcre2-8.so.0
ELF     f75a9000-f75cc000       Deferred        libbrotlicommon.so.1
ELF     f75cc000-f7732000       Deferred        libglib-2.0.so.0
ELF     f7732000-f7741000       Deferred        libbrotlidec.so.1
ELF     f7741000-f7862000       Deferred        libharfbuzz.so.0
ELF     f7862000-f789f000       Deferred        libpng16.so.16
ELF     f789f000-f78b1000       Deferred        libbz2.so.1.0
ELF     f78b1000-f797f000       Deferred        libfreetype.so.6
ELF     f797f000-f79a8000       Deferred        libgcc_s.so.1
ELF     f79a8000-f7a7c000       Deferred        libm.so.6
ELF     f7a7c000-f7c00000       Deferred        win32u.so
ELF     f7c00000-f7e27000       Deferred        libc.so.6
ELF     f7e30000-f7e49000       Deferred        libz.so.1
ELF     f7e49000-f7e5b000       Deferred        libresolv.so.2
ELF     f7e9a000-f7e9f000       Deferred        dnsapi.so
ELF     f7e9f000-f7ea6000       Deferred        ws2_32.so
ELF     f7ea6000-f7f5e000       Export          ntdll.so
ELF     f7f60000-f7f95000       Deferred        ld-linux.so.2
ELF     f7f95000-f7f9a000       Deferred        <wine-loader>
process  tid      prio    name (all IDs are in hex)
00000038 services.exe
	0000003c    0     
	00000040    0     wine_rpcrt4_server
	0000004c    0     wine_rpcrt4_io
	00000070    0     wine_rpcrt4_io
	000000b0    0     wine_rpcrt4_io
	000000c8    0     wine_rpcrt4_io
	000000dc    0     
	000000e8    0     wine_rpcrt4_io
00000044 winedevice.exe
	00000048    0     
	00000054    0     
	00000058    0     wine_sechost_service
	0000005c    0     
	00000060    0     
	00000064    0     
	000000d4    0     
	000000d8    0     
00000068 winedevice.exe
	0000006c    0     
	00000074    0     
	00000078    0     wine_sechost_service
	00000084    0     
	00000088    0     
	0000008c    0     
	00000090    0     
	00000094    0     
0000007c explorer.exe
	00000080    0     
	00000098    0     
	0000009c    0     wine_rpcrt4_server
000000a8 plugplay.exe
	000000ac    0     
	000000b4    0     
	000000b8    0     wine_sechost_service
	000000bc    0     wine_rpcrt4_server
	00000398    0     wine_rpcrt4_io
	000003a0    0     wine_threadpool_worker
000000c0 svchost.exe
	000000c4    0     
	000000cc    0     
	000000d0    0     wine_sechost_service
000000e0 rpcss.exe
	000000e4    0     
	000000ec    0     
	000000f0    0     wine_sechost_service
	000000f4    0     wine_rpcrt4_server
	000000f8    0     wine_rpcrt4_server
	000000fc    0     wine_rpcrt4_io
00000104 RiotClientServices.exe
	00000108    0     
	0000010c    0     AsyncFileLogger
	00000110    0     HttpClient
	00000114    0     
	00000118    0     
	0000011c    0     
	00000120    0     
	0000019c    0     AsyncFileLogger
	000001c4    0     HttpClient
	000001c8    0     
	000001cc    0     
	000001d4    0     HttpClient
	000001d8    0     
	000001dc    0     rg_runtime_worker
	000001e0    0     rg_runtime_worker
	000001e4    0     HttpClient
	000001e8    0     RiotGamesApi-M
	000001ec    0     Disp-1
	000001f0    0     Disp-2
	000001f4    0     Disp-3
	000001f8    0     Disp-4
	000001fc    0     EventCollector
	00000204    0     RmsThread
	00000208    0     
	0000020c    0     ChatExeContext
	00000210    0     Disp-01
	00000214    0     Disp-02
	00000218    0     Disp-03
	0000021c    0     Disp-04
	00000220    0     Disp-05
	00000224    0     Disp-06
	00000228    0     Disp-07
	0000022c    0     Disp-08
	00000230    0     Disp-09
	00000234    0     Disp-10
	00000238    0     Disp-11
	0000023c    0     Disp-12
	00000240    0     Disp-13
	00000244    0     Disp-14
	00000248    0     Disp-15
	0000024c    0     Disp-16
	00000250    0     Disp-17
	00000254    0     Disp-18
	00000258    0     Disp-19
	0000025c    0     Disp-20
	00000260    0     Disp-21
	00000264    0     Disp-22
	00000268    0     Disp-23
	0000026c    0     Disp-24
	00000270    0     Disp-25
	00000274    0     Disp-26
	00000278    0     Disp-System
	0000027c    0     HttpClient
	00000280    0     EventCollector
	00000284    0     
	00000288    0     
	0000028c    0     
	00000290    0     
	00000294    0     
	000002a0    0     HttpClient
	000002a4    0     HttpClient
	000002b8    0     
	000002bc    0     Remoting
	00000330    0     
000001a0 RiotClientCrashHandler.exe
	000001a4    0     
	000001a8    0     
	000001ac    0     
	000001b0    0     
	000001b4    0     wine_threadpool_worker
	000001b8    0     wine_threadpool_waitqueue
	000001bc    0     
	000001c0    0     
000002b0 RiotClientUx.exe
	000002b4    0     CrBrowserMain
	000002cc    0     AsyncFileLogger
	00000300    0     
	00000304    0     BrokerEvent
	00000308    0     TaskSchedulerServiceThread
	0000030c    0     TaskSchedulerForegroundWorker
	00000310   -2     TaskSchedulerBackgroundWorker
	00000314    0     Chrome_IOThread
	0000035c    0     DnsConfigService
	00000360    0     wine_threadpool_worker
	00000364    0     wine_threadpool_waitqueue
	00000368    0     TaskSchedulerSingleThreadCOMSTASharedForeground0
	0000036c    0     TaskSchedulerForegroundWorker
	00000370    0     TaskSchedulerForegroundWorker
	00000374    0     TaskSchedulerForegroundWorker
	00000378    0     CompositorTileWorker1/888
	0000037c    0     AudioThread
	00000380    0     TaskSchedulerSingleThreadForegroundBlocking1
	0000038c    0     wine_mmdevapi_notification
	00000390    0     wine_sechost_device_notify
	00000394    0     VideoCaptureThread
	0000039c   -2     TaskSchedulerBackgroundWorker
	000003a4   -2     TaskSchedulerSingleThreadSharedBackgroundBlocking2
	000003a8    0     TaskSchedulerSingleThreadSharedForegroundBlocking3
	000003b0    0     StreamOpener
	000003b4    0     SelfDestruct
	00000418    0     
	0000041c    0     wine_rpcrt4_server
	00000420    0     CacheThread_BlockFile
000002d0 RiotClientCrashHandler.exe
	000002d4    0     
	000002e4    0     
	000002e8    0     
	000002ec    0     
	000002f0    0     wine_threadpool_worker
	000002f4    0     wine_threadpool_waitqueue
	000002f8    0     
	000002fc    0     
00000384 RiotClientUxRender.exe
	00000388    0     CrGpuMain
	000003e4    0     AsyncFileLogger
	000003e8    0     
	000003ec    0     BrokerEvent
	000003f0    0     Watchdog
	000003f4    0     wined3d_cs
	000003f8    0     TaskSchedulerServiceThread
	000003fc    0     TaskSchedulerForegroundWorker
	00000400   -2     TaskSchedulerBackgroundWorker
	00000404    0     Chrome_ChildIOThread
	0000040c    0     wine_threadpool_waitqueue
	00000410    0     VizCompositorThread
	00000414    0     wine_threadpool_worker
	00000494    0     wine_threadpool_worker
00000424 (D) C:\Riot Games\Riot Client\UX\RiotClientUxRender.exe
	00000428    0 <== CrRendererMain
	0000042c    0     AsyncFileLogger
	00000430    0     
	00000434    0     BrokerEvent
	00000438    0     TaskSchedulerServiceThread
	0000043c    0     TaskSchedulerForegroundWorker
	00000440   -2     TaskSchedulerBackgroundWorker
	00000444    0     Chrome_ChildIOThread
	00000448    0     wine_threadpool_worker
	0000044c    0     wine_threadpool_waitqueue
	00000450    0     GpuMemoryThread
	00000454    0     Compositor
	00000468    0     CompositorTileWorker1/1128
	0000046c    0     CompositorTileWorker2/1132
	00000470    0     CompositorTileWorker3/1136
	00000474    0     CompositorTileWorker4/1140
	00000478   -2     CompositorTileWorkerBackground/1144
	0000047c    0     TaskSchedulerForegroundWorker
	00000480    0     TaskSchedulerForegroundWorker
	00000484    0     TaskSchedulerForegroundWorker
	00000488    0     TaskSchedulerForegroundWorker
	0000048c    0     TaskSchedulerForegroundWorker
	00000490    0     TaskSchedulerForegroundWorker
	000004ac    0     
000004a4 conhost.exe
	000004a8    0     
System information:
    Wine build: wine-8.21
    Platform: x86_64 (guest: i386)
    Version: Windows 10
    Host system: Linux
    Host version: 6.5.13-1-MANJARO

hi can you help me pls.

So does this mean that you are only referring to attempting to run the installers of these 2 games with wine?

For both I would suggest looking at protondb.com

Though, at least in the case of League of Legends, it is available through Steam, which generally takes care of things pretty well.

i know nothing about Lutris,but had a black screen with Proton;
tried a few versions then came back to the latest/or experimental and it worked.

Both games run on the source engine don’t they?
Either way, try changing the version of Wine (in Lutris that’s under the right click-configure menu), under Steam (right click on the game>properties>compatibility).
Most of the time games not launching for me will be fixed by using a different version.

As cscs said, check protondb and see which versions are working for other people.

You are on linux65

…some games didn’t work for me on linux66, maybe try kernel linux61

Thanks for all answers. Now I am using league of legends lutris configurations and i can open the game every settings are working. But now i can’t reach actual game. The server doesn’t open at last part. How can i open this kind of games. (after reach to server gaming)

these are my lutris configurations

have you test this ?

FYI, The Glorious Eggroll has just released a League of Legends specific version of Wine-GE-Proton today, maybe try that:

1 Like