WhatsApp Web deleting letter that starts with accent

I’m not sure if I should post this issue here, if no sorry.

I’m using Gnome with xorg.

What I will describe only happens on Firefox, I have tested it on Google Chrome and seems to works fine.

Since I have reinstalled my Manjaro I noticed that when I try to write a sentence starting with a word/letter that starts with an accent (e.g.: á, é, ó, ô, ê, â) the letter is deleted.

I added a video of the issue:

That’s happens only with whatsapp web on firefox.

shot in the dark, standing on a chair, balancing a beer on my head, that should a million to one chance. and a million to one chances crop up 1 every 10 tries, so this might work:*

change your font, some browser engines have trouble with some characters as input.

* please for the poor attempt at a joke, is was a long day

Hi @Hanzel,

Lol, it’s a good suggestion. I could not think in it.

I tried your approach but isn’t working. Thank you.

Just signed up to say you’re not alone. I’m not a Manjaro user.

I was a Ubuntu user for a few years, tried KDE recently, loved it and yesterday installed Kubuntu.

All was going well, until a few hours ago I noticed the same issue. It seems to only happen on Whatsapp Web, and only if there is an accent in the first letter. Any letter with any accent (I tried ´, ^, ~ and ¨). The problem also seems to happend if you type the accent followed by space, which normally would output the accent alone, but is instead deleted.

Tried changing fonts and languages, both in Firefox and in the System, but no deal.

Also made a video (this forum apparently blocks me from posting it in your post) (also blocks me from posting links):

https: // gfycat . com / enviousdeardegu

That I would like to see.

1 Like

Exactly my problem. I had no idea of what to do to fix it. I’m not sure but I think it’s works fine on firefox on a windows machine.

I just installed Firefox from flatpak instead of using the default snap installation because I was having a few other problems.

Turns out it seems to have solved this one as well. Give it a try yourself. Cheers.

Hi @mazz I have tried your suggestion but the issue still happens even on firefox installed from flatpak. Thanks.

had the same issue using whatsapp web on firefox(linux mint xfce), solved by adding GTK_IM_MODULE=xim on /etc/environment and restarting the session.


Thank you @otonjr that solved my issue too.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.