What is "You need to log in to this network" when activating a wired connection?

Problem

When reconnecting a wired connection after disconnecting, a notification pops up as below


Click “Log in”, it will open “networkcheck.kde.org” in web browser, and displays “OK”.

Version Info

image

More Info

The problem occurs after the most recent big upgrade.
It is not only for KDE, see You Need To Log In To This Network - KDE - Garuda Linux Forum

1 Like

It seems the site used for the network connection check (http://ping.manjaro.org/check_network_status.txt) is currently down and therefore we get this notification.

You can find the address in “20-connectivity.conf” located in /usr/lib/NetworkManager/conf.d

I think the problem will disappear once the site is back up. :crossed_fingers:

7 Likes

Hi @followait,

This usually happens when you are in a captive portal. Somewhere you need to log on to the network to access the internet. It can also appear if the address it’s trying to access to check is just not available for whatever reason.

I don’t know why it says that sometimes when everything is fine. Mine does it too sometimes, but it’s safe to just ignore if everything works.

Hope this helps!

3 Likes

http://ping.manjaro.org/check_network_status.txt shows

404 page not found

If it is only used for checking the connectivity, it’s fine.

BTW, any setting to disable the connectivity checking?

Thanks

1. Solution:

Just create a new file /etc/NetworkManager/conf.d/20-connectivity.conf

[connectivity]
uri=http://networkcheck.kde.org

reboot.
(It is recommended for KDE users as they won’t get confused if this URL should not be mixed with other URL )


OR

2. solution:

Wait for fix the Manjaro URL http://ping.manjaro.org/check_network_status.txt that is in /usr/lib/NetworkManager/conf.d/20-connectivity.conf

3 Likes

Tried this and it works perfectly. :+1:


Didn’t have to reboot. Simply restarting the NetworkManager service was enough. :slight_smile:

sudo systemctl restart NetworkManager
4 Likes

In /usr/lib/NetworkManager/conf.d/20-connectivity.conf

change the uri to

uri=https://networkcheck.kde.org

Restart NetworkManager

Edit: Sorry @Zesko was faster …

Thanks - I had the same query - but it seems just to have fixed itself.

Do not change it in /usr/lib/NetworkManager/conf.d/20-connectivity.conf because it will be overwriten by update or reinstall of Pacman, then the change is gone.

Just create a new separate file /etc/NetworkManager/conf.d/20-connectivity.conf, it won’t be overwritten by Pacman

3 Likes

There’s no GUI setting. To disable it you can create an empty /etc/NetworkManager/conf.d/20-connectivity

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.