What is the difference between Analog / Digital outputs in PulseAudio control panel?

I am perusing the options for “Creative Play! 3” USB DAC in pavucontrol.

In the configuration tab it lists “Digital and Analog” ouputs. Both of them play audio with no issue.

So what is the difference between Digital Stereo Ouput and Analog Stereo Ouput?

I am trying to add a screenshot but the forum doesn’t let me…

if you cannot post a screenshot, use this command to get relevant information in text format
(forum and web searches can find text information better than images)

pacmd list-sinks
1 Like

Generally, analog is considered to be of higher quality, while digital is more suitable for signal processing ─ sampling, digital effects, and so on. :man_shrugging:

1 Like

On my old Windows computer the digital output was for the optical audio output.
edit: and from google it appears it can also be for a coaxial cable too.

Yes, the digital output was needed for the optical drive unless you had a special sound cable connecting your optical drive to your sound adapter. But computer manufacturers stopped adding those cables, and this is why Windows would default to digital output.

1 Like

That is a good tip!

$ pacmd list-sinks
1 sink(s) available.
  * index: 0
	name: <alsa_output.usb-Creative_Technology_Ltd_Sound_Blaster_Play__3_00125254-00.iec958-stereo>
	driver: <module-alsa-card.c>
	state: RUNNING
	suspend cause: (none)
	priority: 9048
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 41.14 ms
	max request: 6 KiB
	max rewind: 6 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	used by: 1
	linked by: 3
	configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
	card: 2 <alsa_card.usb-Creative_Technology_Ltd_Sound_Blaster_Play__3_00125254-00>
	module: 8
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "2"
		alsa.card_name = "Sound Blaster Play! 3"
		alsa.long_card_name = "Creative Technology Ltd Sound Blaster Play! 3 at usb-0000:00:1d.1-1, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.1-usb-0:1:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/sound/card2"
		udev.id = "usb-Creative_Technology_Ltd_Sound_Blaster_Play__3_00125254-00"
		device.bus = "usb"
		device.vendor.id = "041e"
		device.vendor.name = "Creative Technology, Ltd"
		device.product.id = "324d"
		device.product.name = "Sound Blaster Play! 3"
		device.serial = "Creative_Technology_Ltd_Sound_Blaster_Play__3_00125254"
		device.string = "iec958:2"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "iec958-stereo"
		device.profile.description = "Digital Stereo (IEC958)"
		device.description = "Sound Blaster Play! 3 Digital Stereo (IEC958)"
		alsa.mixer_name = "USB Mixer"
		alsa.components = "USB041e:324d"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
		iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
	active port: <iec958-stereo-output>

AFAIK Digital Out is for SPDIF or TOSLINK but then again why is it working for me when I select it? The USB has only analog headphone and mic jacks.

Creative audio devices are usually a bit strange, and this device seems to be true to form!

This looks like a standard analogue usb audio audio device with two 3.5mm jack sockets
Sound Blaster PLAY! 3 - Creative Labs (United States)
and the website makes no mention of IEC958 or SPDIF or Optical

but i still have to ask - can you see a flashing red light in either of the jack plugs?
(I don’t expect there will be for a device that is only $19.99)

iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
is completely illogical in this context

please post some information from ALSA to look a bit deeper down this rabbit-hole

amixer --card=2

if i can make sense of the data in there I would suggest trying to increase basic audio settings
current settings are ok - sample spec: s16le 2ch 44100Hz- but that is just CD quality
This device should be able to work at DVD quality (24bits 48000Hz) no problem

1 Like

No there is no such thing!

$ amixer --card=2
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 44
  Front Left: Playback 44 [100%] [0.00dB] [on]
  Front Right: Playback 44 [100%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume cvolume pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 37 Capture 0 - 30
  Front Left: Playback 31 [84%] [16.00dB] [off] Capture 24 [80%] [24.00dB] [on]
  Front Right: Playback 31 [84%] [16.00dB] [off] Capture 24 [80%] [24.00dB] [on]

Creative claims it can do 24-bit 96kHz.

nothing unexpected in ALSA controls, Looks like a standard USB device

so the mis-identification as Digital IEC958 is only in Pulseaudio. and If Pulseaudio is working ok with ALSA, it is not a major problem

Creative claims it can do 24-bit 96kHz

It can probably do the same in Linux, but I think it is more than most people need, and may not work well on a low-end system

Human range of hearing only goes up to 20kHz at the most. most people cannot hear any audible difference above 48kHz (but it may upset local bats!)
Pushing twice as much data through a system is likely to add some CPU load, and that may be a problem if system is not very powerful. 24bits and 48000Hz is good for most modern systems

The default pulseaudio configuration file for this situation is /etc/pulse/daemon.conf
making a custom configuration file in the home folder allows easier changes to audio settings
default settings are still there as a backup if it does not work out

Open a text editor to make the file

nano ~/.config/pulse/daemon.conf 

(any text editor can be used, but nano is usually available on any version of Manjaro)

and add this text

flat volumes=no
resample-method = speex-float-5
default-sample-format = s24le
default-sample-rate = 48000
alternate-sample-rate = 44100

save the file - Ctrl + W

and exit nano - Ctrl + X

Reboot or restart pulseaudio to load new settings

systemctl --user restart pulseaudio
1 Like

Thank you!

that should sound good

but you can also change sample rate to 96000 easy from there

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.