What is going on with mirrors.manjaro.org/repo?

it’s been 86:05 hours.
not sure if i should use mirrors2.manjaro.org; reading the forum says it is a test mirror.

I think you missed the sync by 2 minutes. It looks up-to-date now.

Aren’t they now pointing to the same source anyway?

1 Like

Hi @linub,

mirrors2 does not work for me, and mirrors.manjaro.org doesn’t have a problem here. So I think whatever’s wrong that you’re experiencing is related to your DNS server/settings.

1 Like

that’s weird and new;never had an issue,nor changed anything

Maybe a caching on your side?

1 Like



1 Like

that’s what i read here:

how do i fix that/clear the cache?


1 Like

That depends on your browser. But this might help:

On the website you’re having trouble with.

1 Like

i don’t think it’s a browser thing since pamac doesn’t get updates either.
and i disabled the Firefox cache:
(from about:cache)

Information about the Network Cache Storage Service
Number of entries: 	0
Maximum storage size: 	32768 KiB
Storage in use: 	0 KiB
Storage disk location: 	none, only stored in memory
Number of entries: 	0
Maximum storage size: 	153600 KiB
Storage in use: 	0 KiB
Storage disk location: 	/run/user/1000/firefox/cache2 

i’ll wait a bit and try to reset my router.
it’s weird that other mirrors are fine.

There are two errors here. One is that your browser shows different information than Mirdarthos’ and mine.

The other one is the actual status of the mirror.

i just noticed the mirror https ://mirrors.cicku.me/manjaro/ which seems to be working for me.
i usually use the following command:
sudo pacman-mirrors --interactive --default && sudo pacman -Syu

now i don’t want to update through Pacman;
can i run the following command without sudo pacman -Syu and then immediately update in Pamac,even though the wiki says:
“Every run of pacman-mirrors requires you to synchronize your database and update your system.”

You don’t have to change your mirror every time you update.

Choose one stable mirror - and stay there - that provides the most stable experience.


until last week i only had https://mirrors.manjaro.org/repo/ which worked fine for me for years.
now that i have this issue,i’d like to add the one i mentioned but without updating through Pacman.
that was my question.

update on the situation:
even though the mirror on the website wouldn’t update for me,i suddenly got a notification from Pamac about updates, which i applied.

then ran sudo pacman-mirrors --interactive --default && sudo pacman -Syu to add the new mirror i found,and funnily enough “mirrors.manjaro.org/repo” wasn’t on this list.

so quit weird.

I have 3 mirrors (1 global + 2 local for backup) and check pacman-mirrors every 3-6 months.
and https://mirrors2.manjaro.org/ has been working well for me

UK mirrors always seem to be out of date in repo.manjaro.org these days, but mirrors in France, Belgium and Germany are good