What else can be done to change my own partition permissions?

Hi !
I have Manjaro latest with LTS kernel .
I have a partition which I need to change it’s permissions to rwx for all user .
I run Manjaro for personal usage. do not consider any security things.
I’ve tried to change the mode and the ownership but it throws the error of read-only file system.
I tried to remount it as read/write, seems to be working with moun -l until I access it . It returns back to ro
here’s the output of some commands you may need
*** IT’S THAT sda2 with 76 GB

loop0 7:0 0 64.8M 1 loop /var/lib/snapd/snap/gtk-common-themes/1514
loop1 7:1 0 229.5M 1 loop /var/lib/snapd/snap/qt513/19
loop2 7:2 0 31.1M 1 loop /var/lib/snapd/snap/snapd/10707
loop3 7:3 0 97.9M 1 loop /var/lib/snapd/snap/core/10583
loop4 7:4 0 55.4M 1 loop /var/lib/snapd/snap/core18/1944
sda 8:0 0 465.8G 0 disk
├─sda2 8:2 0 76.9G 0 part /run/media/abdo/Learn
├─sda4 8:4 0 1K 0 part
├─sda5 8:5 0 300G 0 part /run/media/abdo/Abdo
├─sda6 8:6 0 31.5G 0 part /home
├─sda7 8:7 0 8G 0 part
├─sda8 8:8 0 35.4G 0 part /
└─sda9 8:9 0 571.1M 0 part

mount -l

/dev/sda2 on /run/media/abdo/Learn type vfat (ro,nosuid,nodev,relatime,uid=1000,gid=1001,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2) [Learn]

Thanks in advance.
Best Regards.

Welcome to the forum! :slight_smile:

First of all, the partition in question has a vfat filesystem on it, and vfat is not a UNIX-compatible filesystem. It does not store file ownership and permissions, so the permissions are faked in the kernel’s virtual filesystem layer at mount time and apply to the whole filesystem. They cannot be altered.

Secondly, if you have Fast Boot enabled, then Windows will not properly shut down its filesystems, and then the Linux kernel will interpret this as if the filesystems are damaged. That’s why it will mount them read-only, so as to prevent further damage.

The solution is twofold…

  1. Switch off Fast Boot ─ both in Windows and in the UEFI firmware; and…
  2. Add a record for the filesystem to /etc/fstab, so that it will be mounted statically instead of through the udisks2 framework.

Open up a terminal window, and issue the following command… :arrow_down:

lsblk -o UUID /dev/sda2

Write down the UUID for the partition. Now issue the following command… :arrow_down:

sudo mkdir /mnt/vfat && sudo nano /etc/fstab

Add the following line to the file, but replace the placeholder by the UUID you just copied… :arrow_down:

UUID=the-UUID-you-copied    /mnt/vfat    vfat   auto,nofail,uid=1000,gid=1001,fmask=0000,dmask=0000,umask=000,shortname=mixed,showexec,utf8    0    0

Save the file with Ctrl+O and Enter, and exit the editor with Ctrl+X.

If you reboot now, then the filesystem will automatically be mounted at /mnt/vfat, and it will be world-writable ─ i.e. rwx for all users.


Thank you .
I don’t have windows and I didn’t before Manjaro . I had Ubuntu before it, and also there was the same problem and I think I didn’t overcome it until I formatted the partition as something else but vfat or NTFS, but now I can’t .
I went to the bios, didn’t see a fast boot option, tried to turn off quiet boot but nothing happened.
Yes, I see the files in /mnt/vfat , but they’re still read-only .
somethine else , you see 300GB partition at sda5 Abdo above ? .
It has been totally disappeared. Why ? even when I tried to delete the change of the fstab file it still doesn’t show up . I need it back, how ?
now what ? is there a way I can copy the files in that partition to another one and reformat it as ext4 ? btw , I tried , but threw read-only file system error .

I’ve slightly modified the stanza for the partition ─ I’ve also edited my post above to reflect this ─ so try this now… :arrow_down:

UUID=the-UUID-you-copied    /mnt/vfat    vfat   auto,nofail,uid=1000,gid=1001,fmask=0000,dmask=0000,umask=000,shortname=mixed,showexec,utf8    0    0

I have no idea. It could be indicative of an imminent drive failure, and that in itself could also be the reason why the filesystem is read-only.

Even if the filesystem is read-only, then you should still be able to copy the data from that filesystem onto another one. If you cannot, then ─ again ─ that could be indicative of something being wrong with the drive at the hardware level. :man_shrugging: