What could be the possible cause of "cannot wake from suspend" problem? And how to fix it?

I have ubuntu and manjaro installed on my PC and both of them have trouble waking up from suspend. I made the following attempts but no luck:

  1. rollback kernel from 5.8 to 5.7
  2. turn off secure boot


Every time I tried to wake my PC from suspend, I can see the fans spinning but the display is not light up. There is no signal to the display. I cannot ssh to the PC either.

Error info

I notice there are some error messages in dmesg output:

[   12.670450] rfkill: input handler enabled
[   13.396289] [drm:mod_hdcp_add_display_to_topology [amdgpu]] *ERROR* Failed to add display topology, DTM TA is not initialized.
[   14.581857] rfkill: input handler disabled
[   17.009819] kauditd_printk_skb: 9 callbacks suppressed
[   17.009820] audit: type=1334 audit(1602172881.009:94): prog-id=17 op=LOAD
[   17.009858] audit: type=1334 audit(1602172881.009:95): prog-id=18 op=LOAD

other related info

inxi produces:

➜  ~ inxi
CPU: 6-Core AMD Ryzen 5 PRO 4400G with Radeon Graphics (-MT MCP-) speed/min/max: 2999/1400/3700 MHz 
Kernel: 5.8.11-1-MANJARO x86_64 Up: 18m Mem: 2232.8/14991.5 MiB (14.9%) Storage: 2.29 TiB (3.6% used) Procs: 357 Shell: 
inxi: 3.1.05 


What could be the possible cause of this kind of “cannot wake from suspend” problem?

Since my ubuntn install and manjaro install both have the same problem, could it be the graphics driver that causes the problem?

Any possible approaches to fix it?

I noticed there are many other topics in manjaro forum that are related to this topic. I looked through them and tried some of them but no luck.

Any suggestion is welcome. :dizzy_face:

  1. The full output of an inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  • write down the time

  • go to a terminal and execute systemctl suspend

  • reboot using the REISUB procedure (if possible)

  • post the output of:

    journalctl --system --boot=-1 --since "YYYY-MM-DD HH:MM:SS"

    where obviously --since is the datetime of suspend

use https://textbin.net/ if the output would be too long.


The output of inxi --admin --verbosity=7 --filter --no-host --width is as follows:

  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=358d281b-1623-4cb7-9eca-6bd92cbb0cf0 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Micro-Star model: B550M PRO-VDH WIFI (MS-7C95) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 2.00 date: 06/04/2020 
  RAM: total: 14.64 GiB used: 2.07 GiB (14.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Topology: 6-Core model: AMD Ryzen 5 PRO 4400G with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600103 L2 cache: 3072 KiB bogomips: 88845 
  Speed: 1847 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 
  1: 2016 2: 1348 3: 1400 4: 1401 5: 1357 6: 1400 7: 1399 8: 1400 9: 1585 
  10: 1378 11: 1399 12: 1399 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir driver: amdgpu v: kernel bus ID: 30:00.0 
  chip ID: 1002:1636 
  Display: x11 server: X.org 1.20.9 compositor: gnome-shell driver: amdgpu,ati 
  unloaded: modesetting,radeon alternate: fbdev,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD RENOIR (DRM 3.38.0 5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
  Device-1: AMD vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
  bus ID: 30:00.1 chip ID: 1002:1637 
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 30:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel bus ID: 29:00.0 chip ID: 8086:24fb 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus ID: 2a:00.0 
  chip ID: 10ec:8168 
  IF: enp42s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 2.29 TiB used: 83.59 GiB (3.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Colorful model: CN600 512GB size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: T0629A3 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-22MFCA0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: Seagate model: Expansion size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 8101 
  scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 80.00 GiB size: 78.24 GiB (97.81%) used: 9.92 GiB (12.7%) 
  fs: ext4 dev: /dev/nvme0n1p3 label: N/A 
  uuid: 358d281b-1623-4cb7-9eca-6bd92cbb0cf0 
  ID-2: /boot/efi raw size: 512.0 MiB size: 511.0 MiB (99.80%) 
  used: 28.5 MiB (5.6%) fs: vfat dev: /dev/nvme0n1p8 label: N/A 
  uuid: D34C-62BF 
  ID-3: /home raw size: 100.00 GiB size: 97.93 GiB (97.93%) 
  used: 35.04 GiB (35.8%) fs: ext4 dev: /dev/nvme0n1p1 label: N/A 
  uuid: b34c68f3-623e-40df-ab08-5a56602738c4 
  ID-4: /home/<filter>/job raw size: 100.00 GiB size: 100.00 GiB (100.00%) 
  used: 3.97 GiB (4.0%) fs: ntfs dev: /dev/sda2 label: N/A 
  uuid: 232894BB69D53B86 
  ID-5: /run/media/z/Documents raw size: 250.00 GiB size: 250.00 GiB (100.00%) 
  used: 4.78 GiB (1.9%) fs: ntfs dev: /dev/sdb1 label: Documents 
  uuid: 7D96AB7924913773 
  ID-6: /run/media/z/iso raw size: 200.00 GiB size: 200.00 GiB (100.00%) 
  used: 29.00 GiB (14.5%) fs: ntfs dev: /dev/sdb2 label: iso 
  uuid: 8688E1BE88E1AD3D 
  ID-7: /usr/local raw size: 80.00 GiB size: 78.24 GiB (97.81%) 
  used: 877.2 MiB (1.1%) fs: ext4 dev: /dev/nvme0n1p2 label: N/A 
  uuid: 875370f9-e32f-437b-9e53-46f4feac9460 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.63 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p9 label: N/A uuid: 8a914415-38c9-42fd-b9cb-49eb8c7e4021 
  ID-1: /dev/nvme0n1p4 size: 529.0 MiB fs: ntfs 
  label: \xe6\x81\xa2\xe5\xa4\x8d uuid: EE168B1A168AE347 
  ID-2: /dev/nvme0n1p5 size: 100.0 MiB fs: vfat label: N/A uuid: 0A8C-EFA3 
  ID-3: /dev/nvme0n1p6 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-4: /dev/nvme0n1p7 size: 149.37 GiB fs: ntfs label: N/A 
  uuid: 8C588F18588EFFE6 
  ID-5: /dev/sda1 size: 200.00 GiB fs: ntfs label: N/A uuid: 0B833D52059C3DA8 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-6:2 info: Xiaomi Mi Wireless Combo type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 2717:5010 
  Hub: 1-7:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0608 
  Device-1: 1-7.1:5 info: Seagate RSS LLC type: Mass Storage driver: uas 
  interfaces: 1 rev: 2.1 speed: 480 Mb/s chip ID: 0bc2:2101 serial: <filter> 
  Device-2: 1-8:4 info: Micro Star MYSTIC LIGHT type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1462:7c95 serial: <filter> 
  Device-3: 1-9:6 info: Intel Wireless-AC 3168 Bluetooth type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aa7 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 37.8 C mobo: N/A gpu: amdgpu temp: 29 C 
  Fan Speeds (RPM): N/A 
  Processes: 382 Uptime: 2m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: pacman: 1214 lib: 328 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.05 

I did systemctl suspend and it suspends but I wasn’t able to do a REISUB procedure later. Keyboard not active. The numlock led is not on.

The output of journalctl --system --boot=-1 --since "2020-08-08 00:08:08" is huge and is pasted here: textbin.

OK, the only weird thing that I can find is:

10月 09 08:05:29 z-matrix gnome-session[1087]: gnome-session-binary[1087]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1

So could you do me a favour and:

  • Enable hibernation (You don’t seem to have that active)
  • try to hibernate instead of suspend and see it that works?
    • If not, please report back and we’ll fiddle with ACPI parameters.
    • If yes, That’s your workaround until that gnome bug gets fixed (open/search for an existing bug here)


Thanks for your time Fabby. The hibernation workaround works fine for me. :smile:

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most :
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Got it. I will surely remember to mark the solution next time. :sweat_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.