What can I do to get my display setup working?

That’s the gist of it: what am I doing wrong?!

I’ve used Manjaro for two-three-ish years with problems here and there and a reinstall or two along the way. Then it got royaly broken and I had to go for a reinstall. That moment, I stopped for a distro-hopping moment and end up convincing myself Manjaro was still the way after some test/pen-drives. Installed it and… no boot. I got the advice on what to (possibly) do but just didn’t have more time left at that moment, so I moved on with my Windows install and that’s it.

I did the same thing this week. After reading about uncounted distros, I test/pen-drived Endeavor, OpenSUSE Tumbleweed, Kubuntu and Manjaro. Kubuntu seemed really usable, but the apt thing just felt weird enough I’d just stick with Manjaro, again.

Bear with me I have one of problem-about-to-strike devices: a notebook with hybrid Intel UHD/NVIDIA 3070 Notebooks + external monitor on HDMI + external monitor on a SD4700P thunderbolt USB/displaylink hub.

Aside from the displaylink monitor being dead, all worked well and the Arch Wiki on the displaylink was quite honest so I took the risk. I installed Manjaro.

Boot. Great, the boot issue was no longer present in this version (same machine). But built-in monitor only 's got image. Terrible framerate. No sign of the second monitor. Weird squares around the mouse cursor that weren’t there in the live pen thing.

This’s the second time that whatever stuff that’s done in the pendrive live session (which just works), for some unholy reason, ain’t carried straight to what’s installed on the device and I’m left to spend my time figuring out by myself.

So, really: what am I supposed to do just to get the same result to what the pendrive live thing does in my device?

Do you want to rant or do you want help?

Sounds like you have a hybrid system iGPU+dGPU and you are plugging in to the dGPU, while only the iGPU is enabled by default.

For some reason there have been about a dozen recent threads on the same issue … so look at those.

If you also dont understand how hybrid systems work and/or PRIME … then heres the wiki:

FYI - I edited your topic title - life is to short for rants and [forum rules] apply.

Plasma has a tendency of breaking if you depend on thirdparty plasmoids,extensions,theming et.al. and I have not yet metioned AUR - which for stable branch is a no-go.

That would imply that you didn’t find a working solution there either - welcome back :handshake: :raised_back_of_hand:

That is per defintion a difficult arrangement - vendors wire the displays differently - sometimes using one rule out the other.

Over the years using Manjaro first as a forum member - since 2016 - got a team invitation in april 2017 - that is now the third discourse instance (the past two crashed completely) - I have seen a lot of issues with hybrid laptops and Nvidia.

Nvidia worked reasonably with the Nouveau driver until 10xx series and the pre-10xx Nvidia drivers worked reasonably as well.

I know that because I had a ThinkPad T550 with dual gpu - it worked great.

I did buy a workstation Nvidia card - Quadro I think - to be able to test Nvidia on Manjaro - and worked reasonably well - it was not great - Linux and Nvidia, not a perfect match - so I bought a Radeon WX7100 - and that is great - working OOB.

One thing I have learned about multimonitor setups - use identical monitors - if that is not possible - use highest common refresh rate - usually 60Hz.

Use best quality cables for the refresh rate.

First check the cmdline arguments in the ISO

In grub menu highlight the entry you want to boot and hit e - make notes - hit F10

When you have booted your system check the logfiles in /var/log to see what drivers mhwd found and applied - make notes.

1 Like

this is a problem a lot (if not the most notebook/laptops) suffer from, the external displays do only work properly if the propietary nvidia driver is working. even if some people here still believe that prime would do the job or nouveau is so great because it’s open source…
there is no alternative if you have to stick on nvidia and you’re using external displays or need to use cuda.
you have to choose the propietary driver at the first menu of the setup and there is no guarantee that you have to configure it afterwards if you wanna use kde. but that’s an issue of kde and the sddm.
i was thinking about using amd-gpu’s in future but this isn’t a alternative since they will not support hdmi 2.1. intel-gpu’s might be a alternative in future, but they still suffer from driver-issues and powerful laptops are usually equipped with nvidia-gpu’s. all in we are trapped in a hardware-pitty.

1 Like

All reinstalls I got prior to that one were totally on me and I know it and I accept it. Plasmoids, AUR, that’s life and I’ve always found all info on the risks pretty honest.

As I said, I just didn’t had the time so I stood with a dead partition for months. And I’m actually going for Endeavor right now. :sweat_smile: And it gives gave me pretty much the same thing from pendrive to installed.
But, hey… I’m still on Arch, anyway.

That’s quite my experience, or almost it. I remember I had to use kernel parameters to get the touchpad to work (but I had to do the same on Mint) and to get it to boot with a 1070 (which was a known issue at the time and had this simple solution.
That “royaly broken” thing happened during an innocent sudo pacman -Syyu. Never could roll it back properly, decided for the reinstall and it left me with the paintbrush dangling on my hand.

I have hell here. Not only Intel/NVIDIA crammed inside, but also a FullHD 60Hz 32" monitor, a 2560×1440, 165Hz 17.3" built-in display (scaling hell), and a FullHD 60Hz 23" through displaylink monitor.

Good news the Arch tutorial on displaylink (DisplayLink - ArchWiki) worked perfectly and KDE 6.0.3 is handling multiple scaling options across all displays beautifully so I kind of expect this to carry through to Manjaro users when it gets updated.

As I said, I won’t be testing it for a few weeks, but’ll let it as a possible solution for other users.

Thanks for the caring and comprehensive answer.

1 Like

Arch LInux is the best LInux distribution - I distrohopped back in the days - I fund Cinnarch, later Antergos and ancestor to EndeavourOS.

EndeavourOS has a great community - I’d say it equals Manjaro community.

Manjaro Linux stable branch has Plasma 5.27 - but unstable and testing has 6.0.3, matching Arch Linux - and switching is easy

Logout and switch to TTY - login, execute and reboot

sudo pacman-mirrors -aS unstable
sudo pacman -Syu

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.