(what appears to be) Kernel Panic on Playing Sound from Internal Card

Replaced my XPS 9700 motherboard with one from a 9710. Everything else currently works after some wrangling, except:

  1. the screen will either flash static or go completely black and the entire computer will become unresponsive upon attempting to play any sound from the internal sound card. REISUB/O, which I have enabled through grub, will cease to work at this point, the only option is hard powering off. This does not happen if I play sound through an external card, such as via plugging in a USB-C to headphone jack adapter with a built in TX-384Khz.
  2. brightness settings are not saved, screen goes back to 100% on every boot.
  3. trackpad input sometimes gets “stuck”. It would be slower than usual occasionally, and at other times would randomly exhibit dragging behavior (highlighting text, moving windows etc) from tapping alone.
  4. screen will flash once on boot, and grub has a slow transition from one screen to another in the boot menu. I have not observed these quirks on my prior motherboard, so I figured it’d be worth asking.

Currently 1 bothers me the most, which is why I put it as the title. Both models use a Realtek ALC711-CG, but in my old motherboard this shows up as Comet Lake while the new motherboard displays it as Tiger Lake. This discrepancy and the panic happens on kernel versions 5.10, 5.15, and 5.19. I have yet to try this on a different distro or clean install, and will report back if and when I do.

inxi -Faz
  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=9f1e15e1-145d-4d25-94c0-790195da9733 rw quiet apparmor=1
    security=apparmor udev.log_priority=3 sysrq_always_enabled=1 ibt=off
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9710 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0TXN0W v: A00 serial: <superuser required> UEFI: Dell
    v: 1.2.0 date: 06/15/2021
  ID-1: BAT0 charge: 95.1 Wh (100.0%) condition: 95.1/95.1 Wh (100.0%)
    volts: 13.1 min: 11.4 model: SMP DELL 01RR3YM type: Li-poly
    serial: <filter> status: full
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 built: 2020 process: Intel 10nm
    family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1169 high: 3148 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 993 2: 884 3: 882
    4: 1257 5: 1131 6: 1025 7: 1153 8: 815 9: 1215 10: 1236 11: 3148 12: 801
    13: 1232 14: 1097 15: 1028 16: 816 bogomips: 73744
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:3 chip-ID: 0bda:5510 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2400 s-dpi: 96 s-size: 1016x635mm (40.00x25.00")
    s-diag: 1198mm (47.17")
  Monitor-1: eDP-1 model: Sharp 0x14d6 built: 2020 res: 3840x2400 hz: 60
    dpi: 266 gamma: 1.2 size: 366x229mm (14.41x9.02") diag: 432mm (17")
    ratio: 16:10 modes: 3840x2400
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228e class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: no
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.86 TiB used: 205.26 GiB (10.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: KXG60PNV2T04 NVMe
    2048GB size: 1.86 TiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 10704103
    temp: 29.9 C scheme: GPT
  ID-1: / raw-size: 64 GiB size: 61.94 GiB (96.79%) used: 38.38 GiB (62.0%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 296 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.73 TiB size: 1.7 TiB (98.37%) used: 166.88 GiB
    (9.6%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 68.79 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 344 Uptime: 12m wakeups: 3676 Memory: 62.54 GiB used: 4.33 GiB
  (6.9%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: 1696 pm: pacman pkgs: 1688 libs: 456
  tools: pamac pm: flatpak pkgs: 0 pm: snap pkgs: 8 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21

sudo alsa-info.sh:

Updating system BIOS might resolve some of the hardware issues mentioned
XPS 17 9710 System BIOS | dell.com/support/drivers/

System has a Realtek ALC711-CG audio codec and ALC1309D amplifier/DACs for speaker outputs
XPS 17 9710 Setup and Specifications - Audio | dell.com/support/manuals

ALSA data is showing audio mixer controls for Headphone; Speaker and the amplifier/DAC outputs are muted – [off]

!!-------Mixer controls for card sofsoundwire
Simple mixer control 'Headphone',0

  Mono: Playback [off]

Simple mixer control 'Speaker',0

  Mono: Playback [off]

Simple mixer control 'rt1308-1 DAC L',0

  Mono: Playback [off]

Simple mixer control 'rt1308-1 DAC R',0

  Mono: Playback [off]

Simple mixer control 'rt1308-2 DAC L',0

  Mono: Playback [off]

Simple mixer control 'rt1308-2 DAC R',0

  Mono: Playback [off]

I suggest you use alsamixer to unmute all audio playback controls

sudo alsamixer --card=1

Use keys to select output controls

and M to switch from muted [MM] to unmuted [OO] state

If audio playback is still not working as expected when controls have been unmuted, try using latest kernel v6.0

sudo mhwd-kernel -i linux60

Flashing BIOS did not resolve the issue. Sound cannot be re-enabled via ALSA without triggering an immediate blackscreen. Screen flashing on boot is not fixed but also appears to be harmless. At least brightness and trackpad seem to be working perfectly now. Currently updating my system and kernel before trying again.
EDIT: issue persists on 6.0 and after full system update, returning to 5.15 and using an external card. It is worth noting that I tried to replace the motherboard twice, with the first time being aborted halfway through after I realized the heat sink does not match up, and in the intermission period between the first and second attempts the sound card (which is independent of the motherboard) is recognized by lspci but not by ALSA on the former 9700 motherboard. Is the card itself broken, perhaps?

I take that back. Trackpad will still randomly stick, and appears to do so more frequently and irreversibly (it used to unstick itself eventually and just be a bit slow, now it barely moves and can only be fixed with reboot). The fix appears to involve physically grounding it, which I don’t quite have time for at the moment. Considering the possible damages, I am not inclined to try re-enabling the sound card until there is some kind of a definitive fix.