Well I've done it again. No video signal

I wanted to turn the window borders more transparent, so they’d look like glass. Just a personal preference when it comes to the theme. So I asked the question in the KDE subreddit. The answer wasn’t the one I needed, but that’s likely because the poster didn’t quite understand that I only wanted to change the border, not the entire window. So he gave me instructions on how to make the whole window transparent, which I followed. Upon realizing that this affected the whole window, (and not just the border) I changed the setting back.

That’s when everything crashed. I could move the mouse on the screen, but I couldn’t affect anything. Couldn’t do anything, the computer appeared to have locked up. So I restarted it, hoping this would fix the issue. Now all I can get is the motherboard splash screen, and then a blank black screen. If I hit Ctrl + Alt + F5 button (or was it F4…) I can get a command line, where I can login. As a linux newbie, I can only hope that this is my path to fixing whatever has broken.

Does anyone know what I should do from here? Do I use a command that will reinstall the video driver? Or are there some commands that can identify the problem? I’m using an AMD RX 560 card with whatever drivers Manjaro defaults to upon installation. Thanks!

EDIT: Below is the guide I followed, in error. It doesn’t seem like following it should’ve resulted in this issue, but hey, you never know.

I am not sure what exactly you are trying to do, but to make windows transparent you could use Kvantum, or alternatively this method which does not require any additional program and can be done with KWin settings only:

  • Right click on the window decoratation of any window and select “More” -> “Special Window Settings”.
  • Under “Window Role”, select “Unimportant” from the drop down menu.
  • Under “Window Type”, select everything but Splash Screen and Desktop.
  • Click on “Add Properties” in the bottom left, enter “Opacity” in the search bar and click on both options (active + inactive) that appear.
  • Set the slider to whatever percent you want the opacity to be for both active and inactive windows, then select “Enforce” from the drop down menu. Click on OK.
  • This only changes the transparency for one window type/application. If you want to set transparency for all windows/applications, select “Unimportant” from the “Window Class” dropdown menu.

To make the transparency look better, go to System Settings -> Window Management -> KWin Scripts, click on “Get New Skripts” and search for “Force Blur”. After you have added it, select it from the list of skripts and apply.

Progress! Sort of. If I boot up the computer, and make my way to the command line via Ctrl Alt F4, then I can type “startx” and it will load the desktop! Found that here:

Only thing is, some things are still broken. Firefox won’t open, and neither will the terminal. Dolphin seems to be working fine though. I have to do that every time now, so something is still broken. Any idea what I need to do, in order to fix the problem permanently?

This is exactly the reason timeshift backups are important.

2 Likes

Well I’ve managed to narrow the problem some. Hopefully this will lead me to someone who knows how to fix it.

I can start Manjaro KDE normally using startx. I’ll turn on the computer, it will fail to boot into the desktop, and I’ll press ctrl alt F4. After logging in, I’ll get a command line where I can use the command startx. That loads the desktop just fine. But firefox is broken, which is what I was trying to modify when I broke the OS somehow.

Everything else works fine.

Yes. There is a script you can install with a click that runs Timeshift before an update. I use it and it saved me a world of hurt when my kernel updated to 5.9 and left me with a black screen.

1 Like

Thank you for the reply. However, things like what you’ve just mentioned are why I’m just going to make the switch to Kubuntu instead. I need something more stable than manjaro has proven to be. Both times the video broke, I wasn’t doing anything abnormal. The first time I was just playing a native video game and listening to youtube videos in the background.

This last time I was merely adjusting window opacity settings that come with KDE. It didn’t like that and crashed and broke.

Now I have to use the startx command just to get it to load the desktop. I think Manjaro may be for much more experienced users than me, who are good at fixing things when they break. I’m not that far yet, so I need something that’s a lot harder to break. Thus I’ve decided on a Debian derivative, and one that’ll have Ubuntu’s level of support. I may return to manjaro in 3-5 years when I’ve got the chops to fix anything that breaks.

It’s very clear that it doesn’t like you messing around with video, or using the video too heavily. It’s very fragile in that regard. Maybe it wouldn’t be with Nvidia, I dunno. But I switched to linux to get away from all that proprietary garbage so I’m using AMD for video.

I think it very much depends on which combination of hardware you have. Manjaro is running fine and stable with many of us (including myself on two different machines, both KDE, one with Nvidia drivers) without issues for years. So just to give you a little bit of encouragement, not everybody here (including myself) has a deep knowledge on how to fix every situation.