Weirdly Long Update

I ran sudo pacman -Syu to update my system and it started installing a package called cuda-12.1.1-3 and its been over an hour and it is still installing that first package. Why is this package so big?

Manjaro Unstable

Arch Linux - cuda 12.1.1-3 (x86_64)

downloading 1.4 GB and then unpacking and installing that may take some time
will end up using 4.4 GB - but you already have that used if that is an update

I guess they crammed the whole toolkit in it. If you don’t need it, you should probably remove it.

Removing it, it looks like every package is installing slow. The updates are installing at 100kb per second for some reason.

Because the nature of the problem has changed. I will lock this topic and start a new one.

nevermind i cant

but i am starting a new topic

When I run sudo pacman -Syu to update my system it takes a large amount of time. Even packages like GCC take several minutes. It seems to download at 100KiB per second.

Manjaro Unstable

Could be just the mirror you’re using, maybe try finding a new one before the next time you update.

Why? Please don’t create duplicate topics for the same issue. I’ve merged them.

No, it hasn’t.

Sorry. I did not realize that it was the same question. But i will follow ydar’s suggestion.

Thanks. Your answer worked. I am marking as solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.