Weird wifi issue

First time using manjaro here. after i installed the OS, I noticed my wifi is not working. (no does not scan for wifi). in the terminal i typed rfkill and it showed that the wifi was hard blocked but not soft blocked. i then typoed rfkill unblock 1, the wifi started working normally. The problem is, everytime i restart the laptop the wifi stops working. i have to unblock it thru the terminal again and it starts working again. anyway i can somehow keep the wifi module unblocked everytime the system boots without needing to unblock it thru the terminal? Any help will be appriciated. Laptop: compaq presario cq60

1 Like

Means a switch, like a ‘wifi on/off’ button on your laptop.
Softblock means blocked in software.
Your results of unblocking using rfkill disabling the hardblock are … unexpected.

Please see this for providing information:

i actually tried something: i added the rfkill unblock 1 command on the program startup list and it worked!

Seems more like a dirty workaround than a solution to me.

What does rfkill say about Bluetooth (if your Laptop supports it)?

Do you have a Wifi related button/slider on your laptop?

Try pressing Fn + respective Fx key to switch off/on flight mode.
If that doesn’t help check the BIOS for a Wifi related setting.