Weird titlebar font on LXQT with KWin

Dear Community,

I recently installed LXQT. As I was not satisfied with the appearance of the built in openbox window manager I switched over to KWin. Everything working fine and smooth.

Just one issue that bugs me: The titlebar of the window decorations has a big and fontsize. Unfortunately I didn’t find a way to change the font and the fontsize for the window decorations as the KDE settings manager fontsettings do not work. This also seems to be an issue for other users as there are multiple complaints out in the net about this.

I came across an alternative window decoration theme (Brezze enhanced) which also allows separate font settings.

What I also found out is that there is an alternative way forward to fix that uglyness. Change the fonttype in LXQT settings from Fira Sans to Noto Sans. The result is much better.

Is there another way to modify the font in the KWin titlebar?

Hi,

Unfortunately I can’t help you for your request, I hope an answer for you here

It may be because you do not have installed the systemsettings package.

After install - navigate to the KDE System Settings application

@linux-aarhus it seems not related to the systemsettings package. The issue was there even before installing it. The font settings in the systemsettings do not have any effect.
This seems to be a general problem. All videos LXQT with KWin seem to have that.

I’m happy with my workaround now. Funny effect is, I can’t revert it to the uggly behaviour to post a screenshot… :wink: