Weird behavior when connecting the second monitor


OS: Manjaro Linux x86_64

Host: HP Pavilion Gaming Laptop 15-dk0xxx

Kernel: 5.8.6-1-MANJARO

CPU: Intel i7-9750H (12) @ 4.500GHz

GPU: Intel UHD Graphics 630

GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q

When I plug the HDMI in, the second monitor gets recognized immediately, it turns on and displays a black background. I’m able to move the mouse on the second screen, I can see the cursor moving around, but if I move windows/applications on the second screen, they don’t show up. It’s like it freezes as soon as it gets plugged in, but I don’t know why I’m able to see the cursor moving.

glxinfo | grep OpenGL

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.1.7
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.1.7
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.1.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

xrandr --listmonitors

Monitors: 2
 0: +eDP1 1920/340x1080/190+0+0  eDP1
 1: +HDMI-1-1 2560/598x1440/336+1920+0  HDMI-1-1

inxi -G

Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nouveau v: kernel 
           Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.8 driver: intel,modesetting,nouveau resolution: 1: 1920x1080~60Hz 
           2: 2560x1440~100Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7 

I searched this entire afternoon for a fix, even reinstalling Manjaro from scratch, but nothing.

Can you help me? Thanks!

Hello and welcome,

That means you are using the free drivers and are known to create issues on hybrid GPU Laptops.
You will have to install proprietary drivers trough mhwd UI or CLI.
sudo mhwd -a pci nonfree 0300
will try to install the best proprietary/hybrid drivers for your hardware.
My recommendation is to do it manually.
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

When you want to run an application trough the dGPU you will use prime-run application
AFAIK the 450xx drivers added a fix for external displays connectors.

You can also take a look at the archived forum about Optimus-Manager. Sadly is missing all the pictures and mostly was done for the 440xx drivers, but should help tho. The principle is the same.

When I run this command, nothing happens.

sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime
> Dependencies to install: video-modesetting
Proceed with installation? [Y/n]

and it gives me back the prompt. With the GUI, it gets stucked on:

Waiting for user input...

I have just uninstalled video-linux, though.

Solved with this:

sudo mhwd -i pci video-modesetting

and then running the previous command gets the drivers installed.

Thank you very much, now my second monitor works perfectly.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.