Weird bars before latte-dock or vertical panel appear

i was wondering if someone else have those bars;
they usually appear if i slowly move the mouse towards the dock or panel,which are set to auto hide.
sometimes they also get stuck for a bit,or appear under the dock.


1 Like

seems the same as this issue,it’s just that my panel and dock are much smaller,so so is the Bar.

same problem here

i managed to get rid of the one near the Latte dock and found the culprit;
it’s called “KWin edge”,and there’s a box to uncheck in the Latte dock advanced settings under Behavior/environment.
i don’t really understand what’s the purpose of the Kwin edges,why they appear and how to disable them next to the KDE panel.

1 Like

thanks! that fixed it :grinning:

KWin edges are an important plasma way to communicate a dock/panel with the kwin window manager. If you dont want their visual, you can simple disable them at:
Plasma SystemSettings → Workspace Behavior → Desktop Effects → (disable) KWin Edge effect

1 Like

That fixed it,thanks.
i removed the screen edges functions some time ago,but didn’t disable them under Desktop effects.
it’s weird that for it to work, those black bars needs to appear.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.