WebGL in Firefox 103 broken by default?

Once in awhile I like to visit this little WebGL demo when I’m bored. I noticed that Firefox freezes up, does a complete window redraw then I just see a blank screen and I can’t interact with it like usual. Works fine in Chromium, also fails after trying with a new Firefox profile.

My searches yielded news of a supposed WebGL performance fix on systems running NVIDIA proprietary graphics drivers with DMA-BUF enabled. I search for a DMA-BUF entry in about:config, disable it and it works again, albeit feeling slower than it did via Firefox 102

I’ve an AMD 6800XT. Might someone with Firefox 103, NVIDIA GPU and proprietary drivers confirm if it works/doesn’t work by default without changing this setting?

there is 2 parameters

  • widget.dmabuf-webgl.enabled on true
  • widget.dmabuf-force.enabled on false

this is working for my nvidia card

Yeah, if that first one is set to True for me, nothing WebGL works. It seems to be affecting at least FreeBSD users as well. I’m thinking this works fine for those with NVIDIA cards and not otherwise.

UPDATE: Unfortunately 103.0.1 update doesn’t include a fix, trying to load anything WebGL with this flag enabled with amdgpu crashes the tab.

Addendum: I’m not sure if Office365 uses any WebGL but, viewing the PDF attachment to an email caused an immediate crash and a Process (GPU Process) systemd-coredump until I disabled that setting in about:config :roll_eyes:

UPDATE 2 (08/26/2022): I decided to install the Flatpak, which is at Firefox version 104, and everything WebGL is buttery smooth. Odd side note; A note at the top of the Settings page states “Your browser is being managed by your organization.” Is this normal for the Flatpak?


I couldn’t edit/update my last post. After the 08-27-2022 Testing Branch release, Firefox 104 repository/official version has WebGL running like butter again, too. :+1:t4:

UPDATE: I reinstalled Firefox 104 from the repository (was running Flatpak on desktop) and noticed it still hiccuping on my desktop installation (it was fine on our much lower spec’d laptops when tested and originally made this post). I changed gfx.webrender.all to False in about:config and it was just as smooth again :man_facepalming:t4: (Note; this setting was of no avail either way with Firefox 103)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.