Webcam stopped working

I don’t know why it doesn’t view any video device, I have a ASUS TUF A15 laptop, 1650Ti one. It was working before, now it doesn’t.

I searched online but none of the solutions work. I might have pressed one of the special Fn keys, so I checked by pressing them again(since the symbols are kinda confusing because I don’t see a camera related key), one by one, and checking if the camera turns on, it doesn’t. :frowning:

I also tried to see if keys register, they do, I can get keycodes if I press keys, but don’t know how to interpret them.

Please help.

Commands I tried:

GUVCVIEW: version 2.0.6
GUVCVIEW: couldn't open /home/ceres/.config/guvcview2/video0 for read: No such file or directory
V4L2_CORE: ERROR opening V4L interface: No such file or directory
GUVCVIEW (1): Guvcview error
	no video device found
v4l2-ctl --list-devices

Cannot open device /dev/video0, exiting.

why is no one replying to me :frowning:

Hello @toxicdesire :wink:

Because the information you provide are unspecific… so hard to tell anything.

What did you do before?

What did you try?

Yes, the problem could be, that you turned off the camera by a hardware key… check your UEFI if it is disabled there.

Maybe the webcam just stopped working… hardware failure?

Could your post a full log of dmesg?

sudo dmesg

I’m sorry, I’m new so didn’t know what information should’ve been provided.

It’s working now, I think it was just one of the hardware keys. It’s just sad that nothing appears on the screen whenever those fn+keys are pressed (by accident, for example… on windows it shows a notification).

Thank you for responding.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.