Wayland session only appears after log out but not on boot nor restart

I have followed this tutorial:
[Howto] Use wayland with propietary nvidia drivers (I cant add links)
to enable wayland on my laptop. It has Intel UHD 620 and NVIDIA MX 150. I would like to use wayland when using the Intel card like the last versions of Ubuntu do. I have no problem on using both of them if it works.

The current problem is that after boot or restart, the option to log into the Wayland session does not appear (just GNOME and GNOME Classic). But if after the first login I log out, the Wayland session does appear (GNOME, GNOME Classic and GNOME on XOrg). Furthermore, when I log into wayland, all GNOME extensions appear disabled, (I can enable them) and Manjaro layouts does have all its configuratios as default.

Any ideas?

Adding i915 to /etc/mkinitcpio.conf and running sudo mkinitcpio -P solved it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.