Wayland not installed?

Hi all,

I am new to linux (8-10 years ago i tried mint 17, manjaro, fedora, and elemantary os) but always came back to windows because of my gaming days these days. Since a few weeks i am trying linux again I used Zorin OS 16 for 2 weeks but yesterday i got issues to install nvidia drivers manually and via ppa install. It got a bit messy and i decided to give manjaro a try. Nvidia is up to date and so is everything else phew :slight_smile:

Now my question is, i hear alot about wayland vs x11. I installed manjaro yesterday but it didn’t install wayland. I am still on X11. How can i switch ? i saw a message from a user that said logout and when you want to sign in you can chose, i can’t see any option about this.

Another question, on google i have read that manjaro came stock with steam. When i did a install yesterday i didn’t get steam preinstalled. Which one do i need to install ? native or manjaro version ? or from the website from steam ?

Best Regards,

Hellow, I advise you to create a post for one problem.

U can install Steam on Manjaro Repo (GUI WAY):
U should see an application call Add or Remove Software <-(it’s basically Microsoft Store but 500000000000 times better) open it. Then search for Steam and you should see Steam as the first result or second, click on it and install it.

Install steam via terminal in Manjaro:
You just type sudo pacman -S steam into your terminal. Yup, that’s it. Im not a TRUE GAMER so point me out if you see mistakes.

I know ntg about Wayland sorry

You can use either steam native or steam manjaro whichever you prefer. I’m definitely not an expert but I think one uses the steam libraries and the other the native libraries. I’ve also never used Gnome on manjaro but believe when you login you should be given the option to boot into wayland or x11 session. Which gpu drivers do you have installed

@sawdocter, i don’t get that option sadly. I have the stock nvidia driver installed that came pre-installed

NVIDIA Driver Version: 470.63.01

I’ve seen this post that should help

If everything is up to date:

Log off user, click on the name and then note the tiny wheel at the bottom right -
click offers selection gnome / gnome on xorg the former is wayland -
then enter ship - oh no - password and voila…

1 Like

Hi GaVenga

It’s says in the tiny wheel

gnome - classic.

If you want to run Wayland with Nvidia GPU and proprietary drivers, have a look here:


Ah oke, i stick with x11 then. Thanks for the info.

1 Like

gnome = wayland
gnome-classic = x-11

1 Like

Not quite. GNOME Classic is something completely different.

He does not have Wayland enabled. Therefore both entries will use X11.

With Wayland enabled:

  • GNOME (Wayland)
  • GNOME Classic (X11)
  • GNOME on Xorg (X11)

Thank You…
change the line containing:
# WaylandEnable=false
(= uncomment entry “WaylandEnable=false”)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.