Logging into KDE Plasma using Wayland completely hangs my system

Hello! Firstly, I’m a bit of a newcomer to the Linux scene and have been experimenting with MX Linux KDE and Manjaro KDE, the latter of which I think I’ll stick with; please forgive me for the slightly long post, I’m still figuring out the basics.

I have two monitors that have different refresh rates (144hz on my main, 60hz on my secondary). I’ve read X11 doesn’t particularly support this kind of configuration, so I followed a guide on the KDE website to install Wayland, found here: https://community.kde.org/KWin/Wayland.

The installation went seemingly well, and upon restarting my system SDDM loads without issue, but when I select “Plasma (Wayland)” to log in with, I’m greeted by a black screen with some text on the top left, reading " /dev/nvme1n1p2: clean, 391216/14671872 files, 3863136/58664828 blocks ". Directly below the first forward-slash is an underscore(?) cursor that either blinks or does not blink; I was unable to determine any pattern to whether or not it would blink. I’m unable to input anything on that screen, and as suggested on other articles I found discussing a similar issue, inputting ctrl+alt+f3 does nothing. I have to manually hold down the power button in order to shut the system off.

I tried removing the NVidia drivers and using the video-linux drivers listed in the Hardware Configuration section of the System Settings app, and I tried using a different, newer kernel (5.12.9-1 specifically) but I encounter the same issue either way. I’m back on kernel 5.10.42-1, and encounter this same issue still.

Below is a copy-paste of my System Information from the Info Center app. If there is any additional information needed, please let me know what it is and how to share it.

System Info

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.10.42-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 1600X Six-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NV136

Wayland, on KDE, and with Nvidia on top of that, is not ready. Last time I tried it was working though, but broken as hell. You probably didn’t install what Manjaro was needing for that to work.

It’s not worth the try. Stick to Xorg.

That you will need to explain, first time I read that. What do you mean? Source?

Ah, okay. I’ll stick with Xorg, but am looking forward to any upcoming developments with Wayland. And yeah, I meant source. My bad. Thank you for the pointer!

1 Like

Do you have the egl-wayland package installed? Thats the package i had to install to boot up Wayland with NVIDIA.

I do not. I’ll reinstall the NVidia drivers and give that a shot.

Okay, a bit of a development. Installed egl-wayland, NVidia drivers didn’t work so I went back to video-linux, and it actually managed to log in! Only issue is that the system hangs during the fade-in to the desktop.

At least now I know what kind of set-up I need to do to get Wayland working in the future.

Have had 60hz and 144hz monitors with my NVIDIA GPU on Xorg for close to half a decade now. What issues are you having with this config?

Window movement and resizing seems to be stuck at 60hz, even on the 144hz display. It’s a nitpick, I know, but I figured I’d try to tinker around and see if there might be a fix or something I missed.

1 Like

Can you share the output of xrandr

Sure thing, here you go.


Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
DVI-D-1 disconnected (normal left inverted right x axis y axis)
DVI-D-2 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.00*+ 50.00 59.94
1920x1080i 60.00 50.00 59.94
1680x1050 59.88
1280x1024 75.02 60.02
1440x900 59.90
1280x960 60.00
1152x864 75.00
1280x720 60.00 50.00 59.94
1440x576 50.00
1024x768 75.03 70.07 60.00
1440x480 60.00 59.94
832x624 74.55
800x600 72.19 75.00 60.32 56.25
720x576 50.00
720x480 60.00 59.94
640x480 75.00 72.81 66.67 60.00 59.94
720x400 70.08
DP-1 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 144.00*+ 119.98 99.93 60.00
1680x1050 119.95 59.95
1280x1024 119.96 75.02
1440x900 119.98 59.89
1280x720 60.00 59.94
1024x768 119.93 75.03 70.07 60.00
800x600 72.19 75.00 60.32 56.25
640x480 75.00 72.81 60.00 59.94
720x400 70.08

Does the displayport one have freesync/gsync enabled? If so, disable it then restart.

I don’t have the NVidia drivers installed at the moment, so I’m not sure how to do that. I can reinstall the NVidia drivers and make sure that’s disabled, though.

Please do. It also should be an option in your monitor’s OSD if it’s supported.

Turned off Freesync on my monitor’s OSD, though I can’t seem to find the toggle for forcing gsync with non-gsync display in the advanced tab of x server display configuration. I checked to make sure I selected the correct display, too. Is there a command I can run to find out what its set to?

I forget to tell that i’m using 470 drivers that has better support for NVIDIA on Wayland and Plasma 5.22,maybe that the reason your system hangs. You are installing 465 drivers while 470 are still on testing branch (as well Plasma 5.22).

Ah, I see. I’m going to wait for Plasma 5.22 and/or those 470 drivers to trickle down to the stable branch; I don’t wanna mess with stuff that could brick my install, I’ve already reinstalled Linux eight times this week. Good to know that it works on the testing branch though, hopefully that will apply to stable soon. When that does happen, I’ll try to remember to come back and mark your comment there as the solution.

Ever heard of TimeShift application, and/or the Manjaro live USB?

I am extraordinarily embarrassed to say I didn’t think of that. Damn. I’ll do that.

There are even more solutions to restore your Manjaro installation if you break it if you search on the forum. A reinstallation is really in extreme cases in my opinion. Usually you can reverse what you have done from the Live USB, or simply restore a TimeShift backup, or other backup tool.

1 Like