Wayland doesn't start on GTX 770

Basic info:

KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.17.9-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × AMD FX(tm)-4300 Quad-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 770/PCIe/SSE2

X Server Settings:

inxi:

  Device-1: NVIDIA GK104 [GeForce GTX 770] driver: nvidia v: 470.129.06
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 driver: X:
    loaded: nvidia gpu: nvidia,nvidia-nvswitch resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 770/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.129.06

sudo cat /sys/module/nvidia_drm/parameters/modeset:

Y

What happens:
A cursor on a black screen after login into Wayland session. Then gets back to SDDM

What I tried:

  • 5.10, 5.15, 5.17, 5.18 kernels
  • 390, 470, 510 Nvidia drivers (510 doesn’t start even with X)
  • GRUB_CMDLINE_LINUX=“nvidia-drm.modeset=1”; MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

I’ve looked into several topics and don’t remember everything I did. But I finally got my system broken and had to undo everything over tty.

Might be helpful: Manjaro Gnome worked out of box on both Wayland and Xorg

wayland on kde + nvidia just doesnt work, you wasted your time…

Is there any good DE which not conflicts with Plasma and preferes Wayland ? If everybody is fed up with such issues here I’ll go this way…

Make sure that all required packages to run wayland are installed, then you can log in the wayland session, but it will not work as you might want and there are plenty of issues.

That should be in /etc/grub

that should be in /etc/mkinitcpio.conf

You have to run
sudo mkinitcpio -P
and then
sudo update-grub

Have you done that?

Also, have a look here SDDM - ArchWiki

I did that all, except my grub file is in /etc/default directory. I’m pretty sure these options have been applied as the startup changed slightly. I installed Sway yesterday and it also stucks.

lsmod:

nvidia_drm             73728  8
nvidia_uvm           2576384  0
nvidia_modeset       1204224  17 nvidia_drm
nvidia              35401728  874 nvidia_uvm,nvidia_modeset

Followed SDDM archwiki. SDDM launches, but not sure it launches on Wayland. Also played with kwin_wayland command, it prints some errors:

kf.globalaccel.kglobalacceld: Failed to register service org.kde.kglobalaccel
kwin_core: Failed to update gamma ramp for output KWin::X11WindowedOutput(0x564f3e11b550, name="X11-0", geometry=QRect(0,0 1024x768), scale=1)

Installed packages: