Wayland and other issues using kernels after 6.3 (specific versions like 6.5.0 work)


I’ve been having issues with my manjaro system on my HP zbook studio g5 for a while. While I am trying to keep my sytem upgraded, I started to have issues in the 6.4 series. I am now stuck on 6.1 series. Some versions (for example 6.5.0 and some of the 6.4 series) worked fine.

The way I noticed the issue is that wayland is not working (and fallback to X fails but that maybe due to my optimus setup). However, it seems that there are other symptoms, for example lspci takes forever to finish, I am getting some timeout errors on a specific pci device (which turns out to be the nvidia sound controller), and reboot reset fails (“Software reset failed” - i have to manually turn off the laptop).

I use nvx (GitHub - pedro00dk/nvidia-exec: GPU switching without login out for Nvidia Optimus laptops under Linux) to handle my Nvidia card. However this hasn’t caused issues in the past.

Grateful for any ideas or any checks that I can run. I have started removing all custom kernel options but I don’t see a difference. I haven’t yet tried other distros but may have to do that at some point.


Here is my inxi info

  Kernel: 6.1.54-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=822a4d3f-a5ca-4521-9f9a-b087338b955d rw rootflags=subvol=@
    luks.key=369dc21e-63d5-4dab-b211-3c29f6a5d60f=/crypto_keyfile.bin quiet
    udev.log_priority=3 splash vt.global_cursor_default=0 audit=0
    pcie_aspm=force i915.enable_psr=1 nowatchdog drm.vblankoffdelay=1
    tsc=reliable mitigations=off threadirqs
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP ZBook Studio G5 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8427 v: KBC Version 16.4E.00 serial: <superuser required>
    UEFI: HP v: Q71 Ver. 01.22.00 date: 09/15/2022
  ID-1: BAT0 charge: 12.6 Wh (16.9%) condition: 74.4/96.4 Wh (77.1%)
    volts: 10.5 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging cycles: 373
  Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 1558 high: 2101 min/max: 800/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2101 2: 2100 3: 2100
    4: 2100 5: 800 6: 2100 7: 800 8: 2100 9: 800 10: 800 11: 2101 12: 800
    bogomips: 52815
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Vulnerable
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Vulnerable
  Type: retbleed status: Vulnerable
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: Chicony HP HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:2 chip-ID: 04f2:b5e7
    class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: nvidia failed: intel dri: i965
    gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x33eb built: 2017 res: 3840x2160
    dpi: 284 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 3840x2160
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris wayland:
    drv: iris x11: drv: iris
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.8-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    device-ID: 8086:3e9b memory: 22.17 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.264 layers: 6 device: 0 type: integrated-gpu name: Intel
    UHD Graphics 630 (CFL GT2) driver: mesa intel v: 23.1.8-manjaro1.1
    device-ID: 8086:3e9b surfaces: xcb,xlib,wayland
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: N/A
    alternate: snd_hda_intel pcie: speed: Unknown lanes: 63 link-max: gen: 6
    speed: 64 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k6.1.54-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: yes class-ID: 7c010c
  Local Storage: total: 3.68 TiB used: 3.11 TiB (84.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: HP model: SSD EX950 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SS0221B temp: 31.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:8 vendor: HP model: SSD EX950 2TB
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 42A0S63C temp: 31.9 C
    scheme: GPT
  ID-1: / raw-size: 1.69 TiB size: 3.45 TiB (204.26%) used: 3.11 TiB (90.2%)
    fs: btrfs dev: /dev/dm-1 maj-min: 254:1 mapped: cryptroot
  ID-2: /boot/efi raw-size: 350 MiB size: 346 MiB (98.86%)
    used: 122.7 MiB (35.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.69 TiB size: 3.45 TiB (204.26%)
    used: 3.11 TiB (90.2%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
    mapped: cryptroot
  ID-4: /tmp raw-size: 1.69 TiB size: 3.45 TiB (204.26%)
    used: 3.11 TiB (90.2%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
    mapped: cryptroot
  ID-5: /var raw-size: 1.69 TiB size: 3.45 TiB (204.26%)
    used: 3.11 TiB (90.2%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
    mapped: cryptroot
  Alert: No swap data was found.
  System Temperatures: cpu: 44.0 C pch: 46.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 386 Uptime: 32m wakeups: 1 Memory: total: 24 GiB note: est.
  available: 22.7 GiB used: 5.11 GiB (22.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
  clang: 16.0.6 Packages: 2611 pm: pacman pkgs: 2604 libs: 576
  tools: gnome-software,pamac,paru,yay pm: flatpak pkgs: 7 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.30

Here is a log of a boot with kernel 6.1

Here is a log of a boot with kernel 6.5.4

Firstly, there is nothing wrong with being on 6.1 LTS. There’s a reason why LTS kernels are marked “Recommended” in Manjaro Settings Manager. If you run a bleeding edge kernel you will run into new bugs and regressions at some point, so you might want to reconsider if there is anything in the latest kernels that you actually need.

As for the issue, your BIOS is out of date, try updating it.

1 Like

Thanks @MrLavender. I’ve done the BIOS update - thanks for noticing - but no changes (on 6.5.5).

I get that 6.1 is not bad, but I do have the impression that some interesting stuff that was solved in later kernels. For example with regards to Nvidia Optimus handling, it has been much more reliable to turn my gpu off and on, whereas my external screen sometimes doesnt work on 6.1. I also have issue with sound volume sometimes fading out.

Well, even the 6.1 log has some strange errors that probably should be investigated, but off the the top of my head;

  1. Have you tried disabling the nvx service?

  2. Is there any clue in the Xorg log that it tells you to check?

Sep 28 10:07:54 nk-zbook /usr/lib/gdm-x-session[1719]: (EE) Please also check the log file at "/var/lib/gdm/.local/share/xorg/Xorg.0.log" for additional information.
  1. Is there a reason why your kernel command line parameters are different between 6.1 and 6.5?