Waydroid on the PinePhone

A few questions for PinePhone users.
I managed to get Waydroid to work with ManjaroARM on Phosh but there are a few issues that I’m stuck with:

  • for some reason I need to pass --details-to-std for any waydroid command to work (on Phosh only)
  • I could not find how to install specific android images (in particular I would like to have a fully working MicroG installation, so something like Lineage4Microg)
  • in multi windows mode, the android keyboard also opens in a separate window which is… somewhat suboptimal… (also Phosh-specific bug)

So my questions are:

  • anyone know where that --details-to-std requirement came from and what to do to remove the need for it?
  • any temporary workaround if not? (e.g. how to set a system-wide alias waydroid="waydroid `--details-to-std" that would also work for commands inside .desktop files and user services)
  • how to install an image with preinstalled MicroG or how to post-install it with full spoofing support?
  • how to prevent input methods (android keyboard…) to open in separate windows in multi-windows mode?

Thanks in advance for your help

Some updates since I’ve been testing things in the meantime.

Different things are working depending on the desktop environment (Phosh vs Plasma), which was a little surprising:

  • on the ManjaroARM Plasma version, waydroid can be called directly without --details-to-std, whereas the argument is required for Phosh
  • apparently, according to the Waydroid people, MicroG should be easy to install via waydroid app install path/to/microg.apk but this leads to a non-working installation with the manjaro repo (though signature-spoofing is supported by the image, MicroG does not have access/permissions for it)
  • the issue of the keyboard appearing in a specific window is Phosh-specific, everything works fine in Plasma mobile

As a workaround, I tried to see whether it was possible to use KDEConnect in Phosh to directly use the linux keyboard but this is not user-friendly.
However, KDEConnect kind of works to get the android-app notifications to show up in the linux DE.

About my waydroid install

I installed waydroid from the repos (currently version 1.1.1)
pacman -S waydroid waydroid-image
then, since python-pyclip is missing, I did
sudo pip install pyclip
and then init waydroid via the advised
sudo pkexec setup-waydroid


Worked perfectly for the instagram app - background info: I literally have no other phone where I can see some of the messages my girlfriend sends me when she share funny videos on web version I only see a technical message that I need the app - and on very old phone I have laying around without sd card I also cannot see them. Now on pinephone I can and actually the app seem to work.

Waydroid is a very good thing it seems. Awsome :wink:

I have a small question related specifically to Waydroid on Manjaro’s Plasma Mobile image on the Pinephone: is it possible to separate the icons for the native applications in the app drawer from the icons for Waydroid’s applications?

I’m asking because after installing and starting Waydroid once, suddenly all of Android’s application icons were dumped into the app drawer, making it a bit of a mess :sweat_smile:

That’s something waydroid does. So you would have to take it up with the waydroid developers.

Thanks for the quick reply Strit. Will do! :slight_smile:

If you don’t mind the apps, but only the icons, you can remove them from /usr/share/applications and ~/.local/share/applications.