Waydroid not launching full-ui or any app

Trying to use waydroid on x86 machine. Installation is complete, and everything seems to be fine with waydroid status, which shows:

Session:        RUNNING
Container:      RUNNING
Vendor type:    MAINLINE
Session user:   shaurya(1000)
Wayland display:        wayland-0

However, running waydroid show-full-ui launches nothing, not even an error message. Same with waydroid app launch com.android.settings . Even the logs show nothing out of ordinary:

(019033) [02:41:48] Starting waydroid session
(019033) [02:41:48] Save session config: /var/lib/waydroid/session.cfg
(019033) [02:41:48] UserMonitor service is not even started
(019033) [02:41:48] Clipboard service is not even started
(019112) [02:42:20] % sudo chmod 666 -R /dev/binder
(019112) [02:42:20] % sudo chmod 666 -R /dev/vndbinder
(019112) [02:42:20] % sudo chmod 666 -R /dev/hwbinder
(019112) [02:42:20] Container manager is waiting for session to load
(019112) [02:42:20] % sudo /usr/lib/waydroid/data/scripts/waydroid-net.sh start
(019112) [02:42:20] % sudo waydroid-sensord /dev/hwbinder
(019112) [02:42:20] New background process: pid=19148, output=background
(019112) [02:42:20] % sudo umount /var/lib/waydroid/rootfs/vendor/waydroid.prop
sudo: waydroid-sensord: command not found
(019112) [02:42:20] % sudo umount /var/lib/waydroid/rootfs/vendor
(019112) [02:42:20] % sudo umount /var/lib/waydroid/rootfs
(019112) [02:42:20] % sudo mount /usr/share/waydroid-extra/images/system.img /var/lib/waydroid/rootfs
(019112) [02:42:20] % sudo mount -o remount,ro /usr/share/waydroid-extra/images/system.img /var/lib/waydroid/rootfs
(019112) [02:42:20] % sudo mount /usr/share/waydroid-extra/images/vendor.img /var/lib/waydroid/rootfs/vendor
(019112) [02:42:20] % sudo mount -o remount,ro /usr/share/waydroid-extra/images/vendor.img /var/lib/waydroid/rootfs/vend
(019112) [02:42:20] % sudo mount -o bind /var/lib/waydroid/waydroid.prop /var/lib/waydroid/rootfs/vendor/waydroid.prop
(019112) [02:42:20] % sudo chmod 777 -R /dev/ashmem
(019112) [02:42:20] % sudo chmod 777 -R /dev/dri
(019112) [02:42:20] % sudo chmod 777 -R /dev/fb0
(019112) [02:42:20] % sudo lxc-start -P /var/lib/waydroid/lxc -F -n waydroid -- /init
(019112) [02:42:20] New background process: pid=19182, output=background
lxc-start: waydroid: utils.c: open_devnull: 1209 No such file or directory - Can't open /dev/null
(019112) [02:42:20] Save session config: /var/lib/waydroid/session.cfg
(019033) [02:42:52] waydroidusermonitor: Received transaction: 1
(019033) [02:42:52] Android with user 0 is ready
(019112) [02:43:53] waydroidhardware: Received transaction: 3
(019112) [02:43:53] % sudo lxc-freeze -P /var/lib/waydroid/lxc -n waydroid
(019112) [02:43:53] Save session config: /var/lib/waydroid/session.cfg
(021358) [02:44:08] % tail -n 60 -F /var/lib/waydroid/waydroid.log
(021358) [02:44:08] *** output passed to waydroid stdout, not to this log ***
(021776) [02:49:47] % tail -n 60 -F /var/lib/waydroid/waydroid.log
(021776) [02:49:47] *** output passed to waydroid stdout, not to this log ***

So has anyone managed to get it working? What am I missing here?

Start the init process:

sudo waydroid init

Then start the waydroid-container service:

sudo systemctl start waydroid-container

Yeah, done all that. Running the above command again just says its already initialised. Container service is also running. The problem is occuring after all this when trying to launch ui or apps. Also, i am in wayland session since x11 showed some error that xdg session is not wayland

Well it works well on the Pinephone on Phosh

I am suspecting it may be a x86 or amd graphics issue. Thanks for help though. I will post it as issue in their github repo

same problem here. Tested waydroid on two very different machines (old Intel I5 (4th gen) and one year old ryzen system). Compiled waydroid from the AUR and followed the instructions on waydo.id . No GUI is showing, tho on the Intel machine showed it once, but I dunno why it happened at last :joy:. Worked well so far and suprisingly responsive, until I tried to start it again. :dizzy_face:

Here is the issue on github