Waybar fails to load after system update

I did an update which seems to have solved my issues. I still have no clue about what happened, I can provide more information if you tell me how. The Sway Service session still does not work, and redirect to the login screen after failing to load services. I still have a gray screen for few secs when openning my session but maybe it is normal ?

Still, thanks for the update !

Yes, that is fine-ish (still looking to speed that up eventually).

Hello again,

I’m dusting off this thread after a similar issue with waybar after another system update.

This time it seems despite updating to the most recent version of waybar (0.10.3-1). Whenever it runs I get the following error message

waybar.sh[3340]: waybar: error while loading shared libraries: libspdlog.so.1.13

The most recent version of spdlog is installed (1.14)

This really just seems to be a conflict with wherever the file is being launched from despite updating, reinstalling, running skel then reloading sway.

I know the most recent version of waybar is installed according to pacman, however I cannot get a --version flag from waybar in the cli, it just shoots back the same error pasted above.

So my next step was locating all of the files for the package

pacman -Ql waybar

I have abbreviated the output to the complete paths

… /man/pages

At this point I’m not sure what I need to replace or modify. I have not bothered with trying to play with the systemd unit files and it seems unrelated to this problem.

How do I ensure the correct version of Waybar is being launched?

I think that is the wrong question. Waybar needs to be rebuilt for ARM with the current toolchain. I pinged the @Manjaro-Arm about it multiple times, as I don’t have the permissions and tools to do so.

Looks like arch-arm maintains waybar. The latest version in unstable was built 5 days ago.

[ray@jellyfin ~]$ sudo pacman -Si waybar
Repository      : extra
Name            : waybar
Version         : 0.10.3-1
Description     : Highly customizable Wayland bar for Sway and Wlroots based
Architecture    : aarch64
URL             : https://github.com/Alexays/Waybar/
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : atkmm  cairomm  fmt  gcc-libs  glib2  glibc  glibmm
                  gtk-layer-shell  gtk3  gtkmm3  jack  jsoncpp
                  libdbusmenu-gtk3  libevdev  libinput  libmpdclient  libnl
                  libpipewire  libpulse  libsigc++  libwireplumber
                  libxkbcommon  playerctl  sndio  spdlog  systemd-libs  upower
                  wayland  libatkmm-1.6.so=1-64  libcairomm-1.0.so=1-64
                  libgtk-3.so=0-64  libjack.so=0-64  libjsoncpp.so=25-64
                  libpipewire-0.3.so=0-64  libsndio.so=7-64
                  libspdlog.so=1.14-64  libudev.so=1-64  libupower-glib.so=3-64
Optional Deps   : otf-font-awesome: Icons in the default configuration
Conflicts With  : None
Replaces        : None
Download Size   : 661.51 KiB
Installed Size  : 2358.99 KiB
Packager        : Arch Linux ARM Build System <builder+n1@archlinuxarm.org>
Build Date      : Tue 07 May 2024 03:35:17 PM CDT
Validated By    : MD5 Sum  SHA-256 Sum  Signature