Watchdog did not stop - How to revert blacklist.conf?


I was having the issue related to long time waiting to shutdown or restart the system associated with the message “Watchdog did not stop” so looking to the forum for help I found some threads with indication to a fix the issue as indicated below:

sudo nano /etc/modprobe.d/blacklist.conf
# Disable intel mei (including mei_watchdog).
blacklist intel_pmc_bxt
blacklist iTCO_vendor_support

# Do not load the 'iTCO_wdt' watchdog module on boot.
blacklist iTCO_wdt

Besides the message “Watchdog did not stop” didn’t’ show anymore, the long time remains the same, so I decided to revert the setting deleting the file backlist.conf, but when my system boot it still call the file witch suggest I didn’t made it in the right way. See attached image.

What is the right way to remove the blacklist.conf and the changes it made on the system?

Remove watchdog.conf or whatever you named the conf file. Also remove the nowatchdog kernel boot parameter from GRUB, assuming you are using GRUB. Then sudo update-grub.

safe is safe

$ sudo mkinitcpio -P

none of proposed actions were able to remove the message during the boot.

bellow my current grub file

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=b136d668-4460-4cf7-9211-93b9a5283ab3 udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Uncomment to disable submenus in boot menu

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

If you still have a file called blacklist.conf, can you post the contents of that file? It seems like you have a bad line in there somewhere. Deleting the bad line should, hopefully, fix the issue.
Then regenerate the intramfs: sudo mkinitcpio -P

1 Like

The file doesn’t exist anymore once I deleted it.

I will try to recover it from Timeshift and remove the comment line # and them delete it again.

I have the feeling the the file content was added somewhere because even with the file deleted it’s still being processed.

create a blank blacklist.conf ?

I can’t precise tell what order I made that fixed the issue, but look likes order meter here.

Thanks for all suggestions.

I back with blacklist.conf and removed comments line (the ones started with #), rebooted the system.
Deleted the backlist.conf again and run sudo mkinitcpio -P.

I think that was the order.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.