WARNING: The 'plymouth-encrypt' and 'sd-plymouth' hooks are depreciated

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(usbhid xhci_hcd)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No RAID, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect modconf block filesystems fsck)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev modconf block filesystems fsck)
##   This setup assembles a mdadm array with an encrypted root file system.
##   Note: See 'mkinitcpio -H mdadm_udev' for more information on RAID devices.
#    HOOKS=(base udev modconf keyboard keymap consolefont block mdadm_udev encrypt filesystems fsck)
##   This setup loads an lvm2 volume group.
#    HOOKS=(base udev modconf block lvm2 filesystems fsck)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr and fsck hooks.
HOOKS=(base udev autodetect kms modconf block keyboard keymap consolefont encrypt plymouth filesystems)

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

# Decompress kernel modules during initramfs creation.
# Enable to speedup boot process, disable to save RAM
# during early userspace. Switch (yes/no).

Have added ‘encrypt’ to

HOOKS=(base udev autodetect kms modconf block keyboard keymap consolefont encrypt plymouth filesystems)

? How do I :

You should enable 'lxdm.service', 'lightdm.service' or 'sddm.service' instead.


I don’t understand systemd - ArchWiki.

However, I entered the command:
$ systemctl status

to find:

           │ ├─lightdm.service
           │ │ ├─511 /usr/bin/lightdm
           │ │ └─518 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -n>

So my config appears to be OK. But would still like to know what I would have to do to set 'lxdm.service', 'lightdm.service' or 'sddm.service'

Have checked /etc/systemd/system/: units installed by the system administrator

but cannot see any instance of lightdm in system.conf

Your account is almost 4 years old and if you don’t know how to enable a systemd service then god help you.

In other words, I have to play around to see what works and should have my boot and root partitions imaged in case something goes wrong…

(rhetorical) question is:
Where is this message from?

It is rather likely that you already have a display manager service running.

I got the exact same message from pacman (as @oneno describres) when updating the february bundle package with sudo pacman -Syu:
“WARNING: The ‘plymouth-encrypt’ and ‘sd-plymouth’ hooks are depreciated. You should replace them with ‘encrypt’ and ‘plymouth’ hooks in your ‘mkinitcpio.conf’. The ‘lxdm-plymouth.service’, ‘lightdm-plymouth.service’ and ‘sddm-plymouth.service’ systemd service files are no longer recommended. You should enable ‘lxdm.service’, ‘lightdm.service’ or ‘sddm.service’ instead.”
Hours after my update a depriciated plymouth package became available as per philm revised accouncment notes. After installing this package with sudo pacman -Syuu all was good again.

Check if lightdm.service is enabled and active(running)

systemctl status lightdm.service

If response shows service is disabled

systemctl enable lightdm.service

reboot system and check status again

Thank you for clarifying!

As always, context is important and from the context here it is quite clear what the message meant - of which you apparently only read the last sentence.

The meaning was:
systemd services with names like:
lxdm-plymouth.service, lightdm-plymouth.service and sddm-plymouth.service
should be replaced with:
'lxdm.service', 'lightdm.service' or 'sddm.service'

stop/disable the former and start/enable the other instead - if you have the older variant still

… although I never saw anything else than the latter being used and recommended
these have always been the “default”

lightdm.service appears to be working
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; preset: >
     Active: active (running) since Thu 2024-02-29 19:08:48 PST; 31min ago
       Docs: man:lightdm(1)
   Main PID: 410 (lightdm)
      Tasks: 8 (limit: 27818)
     Memory: 202.2M (peak: 216.7M)
        CPU: 1min 46.488s
     CGroup: /system.slice/lightdm.service
             ├─410 /usr/bin/lightdm
             └─417 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nol>

Feb 29 19:08:48 quest-dev01 systemd[1]: Starting Light Display Manager...
Feb 29 19:08:48 quest-dev01 systemd[1]: Started Light Display Manager.
Feb 29 19:08:50 quest-dev01 lightdm[430]: pam_unix(lightdm-greeter:session): se>
Feb 29 19:08:54 quest-dev01 lightdm[483]: gkr-pam: unable to locate daemon cont>
Feb 29 19:08:54 quest-dev01 lightdm[483]: gkr-pam: stashed password to try late>
Feb 29 19:08:54 quest-dev01 lightdm[483]: pam_unix(lightdm:session): session op>
Feb 29 19:08:54 quest-dev01 lightdm[483]: gkr-pam: unlocked login keyring
lines 1-19/19 (END)

But one of the output in red is:

Feb 29 19:08:54 quest-dev01 lightdm[483]: gkr-pam: unable to locate daemon cont>