Warning: Failed to synchronize database

I re-installed new Manjaro recently and enabled the AUR from pamac gui. I faced with this warning when I tried to refresh the databases from pamac-gtk. I read relevant issues in the forum but couldn’t solve it.
Of course I used yay and it sounds good, but in pamac-gtk it’s not.
I noticed the former AUR repo has been switched to another cdn. I could download https://aur.archlinux.org/packages-meta-ext-v1.json.gz and moved it to /var/tmp/pamac/, but the same warning lasts.

What are your suggestions?

> uname -r: 6.1.49-1-MANJARO

Thanks in advance

Welcome to the forum! :vulcan_salute:

Have you tried… :arrow_down:

pamac checkupdates --force-refresh


Hint: You have to do this without opening the pamac GUI, or else it’ll throw an error.

The CDN has issues with the certificate on some endpoints of their fleet. You can only wait and hope for another server handling your request.


> pamac checkupdates --force-refresh:
Safely check for updates without modifiying the databases (Exit code is 100 if updates are available), and options …

> pamac checkupdates -a:
Your system is up to date.

I solved it by switching mirrors a few times and finally back to Worldwide within a few hours.
Thank you BTW

FYI, mirrors have nothing to do with the AUR. If you think so, you probably shouldn’t be using the AUR because you have no idea what it is.

Please see: Arch User Repository - Manjaro

I got this warning when I pressed Refresh Mirrors, whether I have an idea about it or not.
FYI, I exactly got what I wrote on the topic. If you can help then help! Editing the topic means that I’m so noob to even reporting a simple error in the format of a forum topic!
Thanks for your feedback BTW.

I meant no offense, sorry if I sounded a little short.

Manjaro does store a local AUR database as not to overload Arch’s server.

It seems in the process of refreshing your mirrors, you local database updated. Carry on…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.