War Thunder launcher window black screens when focused

So I went and grabbed the War Thunder launcher off of Gaijin’s website, unfortunately there is no package for it so I went ahead and used the launcher executable in the tar.gz archive.

However, whenever I did so, my screen went completely black, except for my cursor. But I can still switch windows with alt-tab, and whenever the launcher window is not the active window, it shows up perfectly fine.

screenshot: puu.sh/GNaQz.png

The game’s finished downloading and launches correctly, and displays correctly while in game. It’s only just the launcher window that seems to have this issue.

Any ideas as to what could be causing this?

Hi there,
Maybe check your compositor settings - please see if “Allow applications to block compositing” toggle might be to blame.
Also … you may attempt running from terminal to see if any clues pop out.
(ex, going from scrot: ./AppData/Warthunder/launcher)

Changing whether compositing is blockable doesn’t help, and there is no output while the launcher is running from Konsole.

Opening links to the browser from the launcher window and launching the game will both log to Konsole appropriately, but these don’t have anything to do with the launcher window itself.

I have exactly the same problem ! I did some research, and found a topic about this on the warthunder forum.
It looks like it’s driver related, vulkan could be the issue.

Same issue here.
The game won’t even start it’s launcher using Steam…
So i created a manual shortcut on my desktop to launch the launcher and game directly without steam for mean time.

  • steamapps/common/War Thunder/linux64/aces
  • steamapps/common/War Thunder/launcher
    Launcher window has problems though, you need to alt-tab and right click on blank space on desktop to see the auncher at all, which s needed to auto-update the game…

If it would be a driver problem, then why the game works as normal when launching the game directly?
Could you share the link to that forum thread here?

Guess he means this thread

Talking about black screen issues when using vulkan over opengl

Thanks the steam forum is filled with this issue as well:

Confirming, issue is now in-game since the New Power update, and not just isolated to the launcher.

edit: Apparently it’s something to do with Vulkan not being supported with KDE? Seeing as previously the game ran in OpenGL mode.

Src: Warthunder Vulkan without issues. - Linux Related Problems & Advice - War Thunder - Official Forum

edit: Currently, running compiz (or any Vulkan compatible window manager) allows War Thunder to launch and run without issues. However, that means replacing the current window manager with --replace, which needs me to log out of the session and login again to restore kwin when I’m through playing.

compiz --replace

(might need compiz-easy-patch, not sure)

1 Like

I also notice all you people have nvidia.

Anyone tried settings ForceFullCompositionPipeline ?


ForceFullCompositionPipeline does nothing using kwin. (aside from an unrelated konsole output)

(nvidia-settings:95671): Gtk-WARNING **: 20:00:13.616: Theme parsing error: gtk.css:2:33: Failed to import: Error opening file /home/noruzenchi86/.config/gtk-3.0/window_decorations.css: No such file or directory

Looks interesting but I never used that so:

  1. Can we install compiz-easy-patch along-side the current KDE setup?
    Official repos only have this listed when searching for compiz via the search box of pamac GUI.
  2. Do we need to manually execute compiz --replace before starting the game?
  3. Is there a similar command to revert this action?
  4. Do we need to restart Steam or any other app after Question 2?

Currently with the new update v2.x the login screen is black and only shown when briefly when using ALT+TAB…

Compiz really doesn’t like it when I open chromium tabs for some reason. (Having the browser open in the background while I wait for battles …) Freezes the system until it gets interrupted for some reason (eg. pressing power switch to gently logoff/shutdown)

11/18/20 2:18 AM	kernel	compiz: page allocation failure: order:4, mode:0x40cc0(GFP_KERNEL|__GFP_COMP), nodemask=(null),cpuset=/,mems_allowed=0

I’ve heard others using the window manager “awesome” and it works fine for them. Might try that tomorrow.

edit: ew

It was this link but i couldn’t post it in my message. I guess it’s because it was my first message ever on this forum


From what i’ve read, Wayland might also be a solution but it doesn’t work for me, after logging in, I only get a black screen.

Seems there are many many reports there :face_with_hand_over_mouth:

I’m using KDE+nVidia so wayland is not an option for me at moment…

I was facing same issue. It started working today after I used launcher directly to start the game.

cd ~/.steam/steam/steamapps/common/War\ Thunder/

Me too, I tried today and it works again, even in the launcher. I don’t know what gaijin did but now
it seems to work with vulkan.

Fixed with client update

Not really fixed yet, because you still can’t start it via steam…
(Thus you are unable to login to your steam account for the game)

Final fix: (Credits to ripper81 on Steam forum)

  1. Start the “launcher” file from the gamedirectory and let it update the game. to version
  2. Start Steam go to your library and enter the gamesettings dialog.
  3. Enter the following as a startoption: env LD_PRELOAD="" %command%
    This will allow you to start and login to the game using your Steam login/account.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.