Wake on lan not working

Hello everyone,
I am trying to set up wake on lan on my vaio laptop following the Archlinux guide https://wiki.archlinux.org/index.php/Wake-on-LAN but I have not had any success, even after trying the troubleshooting sections regarding realtek ethernet cards. Using ethtool I have verified that the wake on lan with a magic word setting persists after each boot. I know is possible to wake on lan with the laptop’s hardware configuration because I have managed to do it with Windows OS, now I have deleted Windows and only have Manjaro but I have not managed to get it working. the output of ethtool enp14s0 is:

Settings for enp14s0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
                                             1000baseT/Half 1000baseT/Full 
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Link detected: yes

The output of inxi -Fazy is:

System:
  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=cf6a9828-1609-4ace-96c2-328ade52d34b rw quiet 
  resume=UUID=259bd480-9c31-45c7-9bc7-ac83b8f3bf15 udev.log_priority=3 
  r8169.s5wol=1 iommu=soft 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Sony product: SVF1521N6EW v: C10J2KDE serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Sony model: VAIO serial: <filter> UEFI: Insyde v: R0250DA 
  date: 07/19/2016 
CPU:
  Info: Dual Core model: Intel Core i5-3337U bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 14373 
  Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 854 2: 830 
  3: 1064 4: 1223 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Sony driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Sony driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:1292 
  Device-3: Chicony type: USB driver: uvcvideo bus ID: 2-1.3:4 
  chip ID: 04f2:b3aa serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.1 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Sony 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Foxconn 
  driver: wl v: kernel port: 3000 bus ID: 07:00.0 chip ID: 14e4:4365 
  IF: wlp7s0 state: dormant mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Sony driver: r8169 v: kernel modules: r8168 port: 2000 
  bus ID: 0e:00.0 chip ID: 10ec:8168 
  IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 698.64 GiB used: 7.46 GiB (1.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD075 size: 698.64 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 5H scheme: GPT 
Partition:
  ID-1: / raw size: 689.54 GiB size: 677.72 GiB (98.29%) used: 7.46 GiB (1.1%) 
  fs: ext4 dev: /dev/sda2 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nouveau temp: 44.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 171 Uptime: 8m Memory: 5.69 GiB used: 1.06 GiB (18.6%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1030 lib: 293 
  Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.08 

Thank you very much!

I was having the same problem trying to wake from suspend.

If you are trying to wake from suspend then the ethernet may be going to sleep with suspend, check:

  1. that the tlp service is actually running.

    systemctl status tlp

if it is inactive then enable it to make the service run permanently

sudo systemctl enable tlp

  1. Make sure that you have changed appropriate lines in the conf file at /etc/tlp.conf
    Double check that you have removed hash to enable line, so it is not commented out.

    TLP_ENABLE=1
    WOL_DISABLE=N

This worked for me after taking quite a long time to work out what the problem is.

If you are trying to wake from deep sleep (shutdown), then the problem is different and I suspect it could be a BIOS setting.

Hope this helps a bit.

1 Like

Awesome, this fixed my problem! The service was running but I still had to change the lines you specified and now it works even after shutdown.

Thanks a lot!