Waiting for another package manager to quit

Hi,

Im trying to install ProtonVPN on my newly (today) installed Manjaro Linux Xfce4 21.1.6…

BUT, its stuck on:
Waiting for another package manager to quit…

but all package managers are closed except the terminal pacman that the message came on…

pls any help is appreciated :slight_smile:

im very new to Arch/Manjaro BTW

Logout and log back in

i tried already :confused:

Rebooting. I don’t know if it’ll work or not. But it’s worth a shot. Then try installing it with pamac rather than pacman:

pamac build protonvpn-cli

Hello Newbie,

could you post the output of the following command:

lsof /var/lib/pacman/db.lck

:grinning:

thanks! lemme check if it works

did that too

I think that image came all right…


`Edit build files : [e] 
Apply transaction ? [e/y/N] y

Waiting for another package manager to quit...`

still not working…

My command is not solving your problem. It is for searching what your problem is!

Shut all package manager. Open a terminal. Type in:

lsof /var/lib/pacman/db.lck

If it says

lsof: status error on /var/lib/pacman/db.lck: No such file or directory

the problem is in an other position.

If there is no output then ‘db.lck’-file is set (which block your package manager) and no program access it, so you can delete it with this command:

sudo rm /var/lib/pacman/db.lck

If ‘lsof /var/…’ outputs a some programs or PIDs you have to close these programs befor deleting’db.lck’.

OMG it worked my VPN is installing thanks!! :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.