Wacom Intuos Pro Small 2019

Anyone that can help me to get this Wacom up and running on Manjaro Budgie? First I had connection with the pen on kernel 4.19 and pen/touch on kernel 5.3 but the system didn't recognize the tablet at all. Now I don't have any connection at all, either cable or BT (I tried some diff drivers...).

input-wacom-dkms-git 0.44.0-1
libwacom 0.33-1
xf86-input-wacom 0.37.0-1

You don't need them both, they interfere one with another. Go with xf86-input-wacom only. libwacom is installed by default and that has the ID descriptions of the tablet, so keep that one too.

You are wasting your time. Not because is not a good edition and DE, but you will not be able to set up the tablet trough UI, only trough xsetwacom commands, and since Gnome made major changes, the Gnome-System settings do not load and is quite possible that at one point you will not be able to initialize the Desktop Session at all.
My suggestion is to go either with KDE Plasma and install kcm-wacomtablet that will automatically install the xf86-input-wacom package, or go with Gnome and you only have to install the xf86-input-wacom so the Stylus can be also configured trough Settings > Tablet UI.

Update:
Most of the issues seem to be solved on unstable branch, regarding the Budgie and Gnome 3.34 transition. The Wacom Tablet settings is back on working, so you are safe on that matter.

The Wacom Tablet program you show in that screenshot, I assume is the Gnome one, is it possible to get that in XFCE?

I just got the new Intuos Medium today and I thought for some reason XFCE had a built in Wacom settings manager, and the wacom-utility program in the AUR doesn't even recognise the tablet I have.

No, sadly that is no longer the case. The Gnome-Settings doesn't work anymore in XFCE and all that works now is to make use of xsetwacom commands. Depending on how new that model is, it might be or not supported by the xf86-input-wacom (that mostly helps to identify the Stylus and map it to the tablet surface area), while libwacom might or not have the ID of that model.

That is some sort of red hering application. It doesn't work no matter on how many installs i tried it ...

One nice software is this one


The problem is that is using old libraries, and might or not be ported to newer version of PyQt and python3 ... We have to wait and see.

You could try to switch the DE to Gnome or KDE Plasma and see if that changes things for you.
Also Cinnamon DE has a GUI for tablet settings, but lacks some basic functionalities and nobody there wants to change them ...

Well, I've gotten xsetwacom commands to work, and the system recognises the tablet no problem. Basically it sees the tablet just fine, but I can't modify it's settings in any graphical manor, and looked here to see if anyone had figured out a good solution or if there was something I was missing

The Arch Wiki had a few things for using xsetwacom to get some of the basic things I wanted to get working to work, but I think it said all that stuff is temporary, and I'd have to redo it on reboot/replug, which is tedious and annoying. It doesn't help that I use Ultrawide monitors, so getting the resolution and stuff all figured out so it didn't skew my inputs was interesting.

What I want is just a GUI that lets me do the basic stuff like set the focus to a single monitor, set up the quick buttons, and adjust the resolution/pressure stuff all in one nice place.

I've had my XFCE setup for 3ish years now and it works for me, I don't intend to change it for a single program, when everything else I use works just fine

You can always create bash scripts for xsetwacom commands to have them at hand, or even load at startup.
I know of another intention from a couple of developers, to start a project to add Tablet Settings to XFCE, but there was no progress on it for 2 years, not even the readme file ...

Here you might find some examples/resources to make use of scripts, so the xsetwacom commands become more easy to use
https://www.davidrevoy.com/article332/tablet-history-log

Forum kindly sponsored by