VSCodium AppImage won't launch; symbol lookup error; libgio

I’m having a rather frustrating problem. I’m not sure if the issue is the VSCodium AppImage, the AppImageLauncher program, or something else. I swear to you that yesterday all was well but today this app will not run on either my laptop or desktop. I’ve had codium installed on my laptop for months now, running from an AppImage integrated with AppImageLauncher. For some reason when I tried to launch it today nothing happened, checked htop and found no related processes. I tried executing the AppImage from a terminal and got a lengthy response:

$ ./VSCodium-1.60.2-1632356529.glibc2.17-x86_64_ce2cf1cbe05af7a30046e6a674cacc34.AppImage

** (AppImageLauncher:4602): WARNING **: 17:24:21.985: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Matcha-dark-sea/gtk-2.0/assets/trough-progressbar.png: Failed to load image “/usr/share/themes/Matcha-dark-sea/gtk-2.0/assets/trough-progressbar.png”: Fatal error in PNG image file: bad parameters to zlib

(AppImageLauncher:4602): GdkPixbuf-CRITICAL **: 17:24:21.985: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(AppImageLauncher:4602): GdkPixbuf-CRITICAL **: 17:24:21.985: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

** (AppImageLauncher:4602): WARNING **: 17:24:21.985: Invalid borders specified for theme pixmap:
borders don't fit within the image

(AppImageLauncher:4602): GdkPixbuf-CRITICAL **: 17:24:21.985: gdk_pixbuf_get_n_channels: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(AppImageLauncher:4602): GdkPixbuf-CRITICAL **: 17:24:21.985: gdk_pixbuf_get_pixels_with_length: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(AppImageLauncher:4602): GdkPixbuf-CRITICAL **: 17:24:21.985: gdk_pixbuf_get_rowstride: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

The last three lines repeat several times and the last output is:

codium: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

The last thing I remember changing about my system was the Qt theme I changed it from “kvantum” to “gtk2” because I recently installed DigiKam and was blinded by the default white appearance. I had used codium with no issue several days after installing DigiKam and making these Qt changes, so this may be a red herring, but I switched reverted my Qt settings anyway. The Codium AppImage still would not launch but I no longer get the GdkPixbuf warnings. Just the symbol lookup error. At first I thought this may be a bug with AppImageLauncher. I opened an issue on their GitHub and was promptly shut down.

I uninstalled AppImageLauncher, deleted any Codium-related files (the AppImage, config files, icons, were all I found), downloaded the latest Codium AppImage release from their GitHub. At this point, when I execute the AppImage I only get the symbol lookup error message. Re-installing AppImageLauncher and launching the AppImage again produces the same GdkPixbuf warnings with some more output:

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 553, resource id: 11060910, major code: 40 (TranslateCoords), minor code: 0
Extracting usr/share/icons/hicolor/128x128/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/128x128/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/icons/hicolor/256x256/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/256x256/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/icons/hicolor/32x32/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/32x32/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/icons/hicolor/48x48/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/48x48/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/icons/hicolor/512x512/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/512x512/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/icons/hicolor/64x64/apps/vscodium.png to "/home/denny/.local/share/icons/hicolor/64x64/apps/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_vscodium.png"
Extracting usr/share/mime/packages/codium-workspace.xml to "/home/denny/.local/share/mime/packages/appimagekit_9046ca93a33e84c4fb8d990e2e55dae5_codium-workspace.xml"
WARNING: Unable to resize the application icon into a 128x128 image: "Unable to load image.". It will be written unchanged.
WARNING: Unable to resize the application icon into a 256x256 image: "Unable to load image.". It will be written unchanged.
gtk-update-icon-cache: Cache file created successfully.
which: no gtk-update-icon-cache-3.0 in (/home/denny/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/denny/bin)
which: no update-icon-caches in (/home/denny/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/denny/bin)
codium: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

What draws my attention are the two lines starting with WARNING. Something (AIL? A shell script?) was unable to re-size an icon. Perhaps this has something to do with GDK?

I am able to replicate all of these problems exactly on my desktop machine (also running Manjaro XFCE), which has never had VSCodium installed on it but I have used the same “Qt 5 Settings” app to make changes to my Qt theme there. Still not sure if that is related or not…

My current theory is that the Qt settings have something to do with it. Between changing the Qt settings, Codium must have updated itself but the problem did not occur until I restarted the machine several days later. I’m about to file an issue on VSCodium GitHub but first I want to be sure the problem is with that application and not Qt, GTK, or GDK.

I am very lost here. The whole reason I even used the AppImage in the first place instead of building from source was because I thought I could avoid problems like this!

I have since tried running the VSCodium AppImage on another little-used laptop. This machine is running Manjaro KDE. This machine has never had codium installed on it and I’ve never fussed around with the Qt settings. Since I haven’t used this machine in a while, I ran a pacman update first. AppImageLauncher is also installed on this machine. When I executed the AppImage, again the program did not start but I did not get any of the GDK warnings. This time it was only the symbol lookup error again.

This is confusing. It’s looking to me like the problem is with the image. But I thought AppImages came with all the application dependencies. So why is it trying to use some library on my system?

same with old version …

> /home/patrick/Téléchargements/VSCodium-1.60.2-1632356529.glibc2.17-x86_64.AppImage 
codium: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

> /home/patrick/Téléchargements/VSCodium-1.60.0-1630974030.glibc2.17-x86_64.AppImage 
codium: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

glib2 : [Solved]navicat report error after update system / Applications & Desktop Environments / Arch Linux Forums

Thanks. I followed that post and succesfully patched the Codium AppImage. The next time I executed I got another error:

codium: symbol lookup error: /usr/lib/libtracker-sparql-3.0.so.0: undefined symbol: sqlite3_expanded_sql


Now what? Patch it again? Keep patching until it works? Also I’m still confused as to what the real root problem is here. Does the latest release of Codium have bad/outdated libraries?