VSCode IntelliCode Language server error with Python (with fix)

Since yesterday, I’ve been experiencing an issue with the VS Code IntelliCode extension when using it with Python. The error suggests that IntelliCode is unable to locate the language extension server.
I managed to reproduce it

Steps to Reproduce:

  1. Set up a fresh instance of Manjaro KDE.
  2. Install code, code-marketplace, and code-features-insiders packages.
  3. Launch VS Code and try using the IntelliCode extension with Python.

Expected Behavior:

IntelliCode should seamlessly work with Python without any errors.

Actual Behavior:

Received an error about IntelliCode not being able to find the language extension server.

Error Outputs:


Language server is set to "Default". Pylance is used as current language server.
Acquiring model
vs-intellicode-python was passed a model: {}.
Acquiring model 'intellisense-members-lstm-pylance' for python
Querying IntelliCode service for available models.
Cached model is up to date.
Activating Python extension
Language server extension command failed. Exception: Error: command 'python.intellicode.loadLanguageServerExtension' not found
    at y.k (vscode-file://vscode-app/usr/lib/code/out/vs/workbench/workbench.desktop.main.js:1510:12265)
    at y.executeCommand (vscode-file://vscode-app/usr/lib/code/out/vs/workbench/workbench.desktop.main.js:1510:12194)
Error while activating Python: {}

Additional Information:

  • VS Code Version: 1.81.0
  • Python Extension Version: v2023.14.0
  • Manjaro KDE Version: 23.0.0

I’d appreciate any help or insights on this issue. Thanks!
Even though i found a fix (not using pylance) any new user will get this error on a fresh system.


in settings.json set:
"python.languageServer": "Jedi"

Encountered the same issue today.

  • VSCodium Version: 1.81.1
  • Python Extension Version: v2023.14.0
  • Manjaro XFCE Version: 4.18

Rolling back the Pylance extension package to version v2023.6.40 did the trick for me.