Vscode crashes right after start up

Hi since I updated to version 1.90 of vscode, it crashes after start up.

The crash is related to the maximization of vscode windows, since I unmaximize them, it works fine.

The detailed process to reproduce the crashes are:

  1. Open a few vscode windows (I did 6 of them)
  2. Reboot, vscode will remember the opened windows
  3. run code when vscode trying to open multiple windows, it will crash

More details please see here

I’ve updated to the latest 1.90.2 and the problem persists.

Is vscode installed from the official Manjaro repositories?

sudo pacman -S code
1 Like

Na, from AUR, I have to since I need remote ssh

Hi @Shore,

Run it from a terminal emulator:


…and see if there are any errors that give you a clue.

I have the one from the extra repository, and I just tested now:

$ code

…and have no problems.

Also, try rebuilding it if it’s from the AUR.

1 Like

hi I tried and it provide nothing, I also tried code --crash-reporter-directory /home/shore/文档/conf/vscode-crash-report --verbose > log

The detailed report is in this link


That IS weird, yes. The version in the repository is only 1.89, so it might not be present. You can:

  1. Try resizing the not-maximized window to the size of your monitor; and while this might not fix the problem, it is a temporary workaround.
  2. I don’t know if this’ll work for AUR packages, but you can try downgrading the package, presumably using:
    manjaro-downgrade <packageName>

Note: to use manjaro-downgrade make sure it’s installed first:

pamac install manjaro-downgrade


Another option, possibly better depending on your requirements, is to use the one from the repository, and use any of the extensions from here:


1 Like

Hi I found this post and downgraded to 1.89. Thanks

1 Like

And… Did that fix your problem?

If so, please mark the post that led you to this as the solution.
(Hint: Use the :white_check_mark: under whichever post that was.)

Nevermind. I’ll do it for you.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.