VScode cost extensive time to load terminal

Hi I’m running manjaro xfce, using AUR’s vscode package visual-studio-code-bin, as my main coding tool.

It was OK, but just now I the machine was in sleep and I made a hard power out and restart.

After that, each time first start vscode after boot, it cost extensive time to open terminal.

I do not know the reason, I deleted any of the relate files and re-installed it, but nothing works…

Hi I just found out that once I connect to VPN, the terminal shows. When I was disconnected to the VPN, the terminal is not showing.

The time it went to sleep, I was connecting to VPN.

Another thing is when disconnected, I cannot search extension …

Hi @Shore,

Instead of that version, I recommend Code OSS from the community repositories:

$ pamac search code

code                                                                                                                                                                                                  [Installed] 1.64.2-1                        community
The Open Source build of Visual Studio Code (vscode) editor

But this one is forked from the original and doesn’t contain all the Microsoft telemetry stuff from the other one. And since it’s in the community repositories, it can be installed with:

pamac install code

If you wish to access the Marketplace, also install code-marketplace:

pamac install code-marketplace

Try it, it might just help/fix your issues, seeing as I don’t have it.

1 Like

Hi I would have to use remote-ssh, which is not supported from that, T T

If you mean the extension, it was probably because it couldn’t be installed from the marketplace, right?

Na, I forgot about the exact error report, but basically saying that extension of remote-ssh was not supported, using the AUR one instead… It can be installed, but not working…

OH, OK. Then, no idea further.

:man_shrugging: :sob:

Thank you anyway … Hope someone know the issue, it is probably a net issue, because once I connected to the VPN, it alives…

VPN on when hard disconnect - then your DNS resolver is wacked.

1 Like

Hi, I have tried to reset dns file and restart network service, but still not working… What should I do…

Troubleshoot …

Hi, I can ping and do things normally, but only the vscode has problem…

I have only sporadic checked out VScode - it does not fit my usage - perhaps when I get to AL language - it should be superior in that area.

Check your settings in VScode - where you define the URL for the marketplace ( no I don’t know where they are )

Hi, sorry for the late replay, I actually mopped the system and re-installed, still not working