VS Code Syntax Highlighting Not Working

VS code and Vscodium on Manjaro, installed via pacman or from AUR, does not have proper intellisense or syntax highlighting behavior. Below is the issue:

Screenshot_20231201_150305

Firstly, there is no highlighting of the imports, call to the Node() object, or method call on the Node() object. I would expect highlights for all of these.

Secondly, intellisense did not do any auto-completions when writing the initializer, which it always does when I’m working on my mac.

Things I’ve tried:

  • Installing/reinstalling python extension, which includes pylance
  • Installing magic python
  • Changing my python.languageserver to pylance. When I do this I get a popup upon opening vs code that says “The pylance extension is not installed but the python.languageServer value is set to “Pylance” Would you like to install the Pylance extension to use Pylance, or revert back to Jedi?”. When I click “Install Pylance”, nothing happens. But I know that it should already be installed via the python extension. I suspect this might have something to do with the buggy behavior described.
  • All these things but on VScodium

Any ideas on how to fix this?

None. Except to suggest there are other extensions for code highlighting. It might be worth trying a few others. That’s all I have. Good luck.

Thanks. I’ve tried that as well. Nothing seems to change the highlighting.

None about this, in part6icular, but try Code - OSS from the rep[ository:

$ pamac search code
[...]
code  1.84.2-1 [Installed]                                                                                                                                                                                                                              extra
The Open Source build of Visual Studio Code (vscode) editor

So can be installed with:

pamac install code

Enable the marketplace, if you want it with code-marketplace, from the AUR:

pamac build code-marketplace

I don’t know if it’ll make a difference, but it’s worth a shot.

:man_shrugging:

Hope it helps!

Edit:

I use the Code - OSS along with Open VSX Registry and it works fine for me:

https://open-vsx.org/

Thanks, but same issue

Well, I’m using Code from the official Manjaro repositories. This is the result without any extensions installed:

Screenshot_20231202_011315

And, with the Prettier and Python Intelliense (Pylance) extensions installed, the highlighting is identical to that image. I’m not suggesting Prettier has any affect on highlighting; just that it’s installed.

The highlighting, again, remains the same with MagicPython installed.

In all cases the highlighting is consistent with the image I posted, with the obvious differences from the image you posted. Perhaps, try this version instead of the builds you tried.

1 Like

Thanks, which version?

edit:
Oh you mean from the manjaro repositories. I tried this; purged everything related to vs code, reinstall with pacman -S code… same issue

Code OSS (inherited from ArchLinux)

sudo pacman -S code

Then my official analysis remains :person_shrugging:

Try some other code samples; xml, html, css, and others. See if you notice inconsistencies with those also. This may also be helpful:

I tried just reinstalling my OS, and that fixed the issue temporarily, but now the syntax highlighting is gone again… very strange. Would really like to fix this

Which theme do you use?

What did you install after the issue apparently seemed fixed?

Link only for reference: Visual Studio Code

1 Like

Please provide the output of:

code --list-extensions --show-versions

You need to install the language server packages

 $ pamac search vs code --no-aur
vscode-markdown-languageserver  1.85.0-1                           extra
    Markdown language server
vscode-json-languageserver  1.85.0-1                               extra
    JSON language server
vscode-html-languageserver  1.85.0-1                               extra
    HTML language server
vscode-css-languageserver  1.85.0-1                                extra
    CSS/LESS/SCSS language server
texlive-mathscience  2023.66594-19                                 extra
    TeX Live - Mathematics, natural sciences, computer science
    packages
texlive-latexextra  2023.66594-19                                  extra
    TeX Live - LaTeX additional packages
code  1.84.2-1                                                     extra
    The Open Source build of Visual Studio Code (vscode) editor
1 Like

Strange. I don’t have it installed:

$ pamac search -i vs code
code  1.84.2-1                                                                                                                                                                                                                                          extra
The Open Source build of Visual Studio Code (vscode) editor

…and everything seems to be working. Or I’m missing something. Perhaps because I’m not testing with Python?

Edit:

Possible, because when I type the python in the screenshot, it looks the same as the “wrong” one here…in which case, :man_shrugging:

Edit #2:

Either that, or I didn’t care to notice until now… :man_shrugging:

Change your theme.

1 Like

Ultimately I think it was rainbow csv causing the issue. I reinstalled the OS, highlighting was working for a time, then randomly stopped (not so random in hindsight). I would usually click install rainbow csv when it recommends it. This time I reinstalled again and tried to keep it bare minimum, and it’s been working.

EDIT:
But deactivating and even uninstalling it, does not resolve the issue. I had to have never installed it in the first place.

I notice Rainbow CSV hasn’t seen any significant work in the past few years; some of the forks, up to five years. There’s been some activity within recent weeks, but still, no release since 2018.

If Rainbow CSV’s functionality is desired, the obvious choice now is to find a replacement. May I suggest creating a VM to test the new additions, just for the sake of caution.

Before you do so, it might be worth looking through cache/config folders (or node_modules, depending on how it was installed) and make sure there are no residual traces of Rainbow CSV.

This bug RBQL with Python error #148 could possibly be the root cause. If so, it seems like a comparitively easy fix for the dev(s) concerned; but I see no affirmative action.