VS Code - OSS (official repository), wayland, no window border

I am using Wayland fractional scaling. By default it starts in Xwayland and blurry. If I run it with the following command, it is not blurry, but it has no window border. Is this a bug of VS Code itself? Can it be fixed?

code --enable-features=UseOzonePlatform --ozone-platform=wayland

wayland is - in many ways - immature and as such it often cause frustration - there is not much to do other than using the alternative X11

2 Likes

Do you have somewhere the environment variable
QT_WAYLAND_DISABLE_WINDOWDECORATION=1
Maybe use with QT_WAYLAND_DISABLE_WINDOWDECORATION=0

No, no such variable.

I think Wayland is close to be being usable. At least with GTK apps. It is mostly just apps that use other technologies like QT, Electron, Java, etc, that have problems. I had problems with X11, like screen tearing and no per-screen DPI, etc, so I do not want to go back.

Well, if there currently is no way to fix this, then I can just use it as it is until they finally fix it. I can still press alt+space and invoke the move command.

Try with this command:

code --enable-features=UseOzonePlatform,WaylandWindowDecorations --ozone-platform=wayland

You can also try adding "window.titleBarStyle": "custom" in your settings.json file. Similar issue: