VPN - "Use only for resources on this connection" not working

The option “Use only for resources on this connection” on the IPv4 Routes tab is not working; all traffic is being send to the VPN(pptp) and the internet is not reachable through the default route.

I tried setting up the connection via the nm-connection-editor and using
“nmcli connection modify ipv4.never-default yes” but those don’t work either.